Wifi constantly "no internet"


Some strange thing happened to my galaxy s9 today.
I realized that my WiFi is constantly not connected or more precise, has no internet access. However all other devices in my house are working fine. Even other smartphones.
I restarted several times the phone, the router and also switched WiFi on and of.

Any idea what this could be about?!?


Here the same with an iode-OS Fairphone 4.

We use AVM fritz.box router in a mesh network. Quite strange…
The phone is getting a IP from the DHCP. All other network devices are fine.

Yes, the same with my set up. We use a synology router. Also here,the dhcp works and I can see the device in the network. Actually I even can access the Internet although the phone tells me “no internet”.

You are right! So it is just a visual problem.

I see that my FP4 stuck on iode-os version 2.3. I try to update to 2.4.

Perhaps this fix my issue…

I am in 2.4 actually.

Also ,I am not sure if this is only visually.

I need to “force” my phone to use a wfi connection that has no internet - although it has.

Some applications tell me to connect to the internet and thus making trouble.

Hence, if I am not the only one having this issue,I hope there is a way to fix it via an update maybe.

Can you tel me more about your wifi? WPA3, WIFI4?

Wpa2 2,4 an 5 g network

Anyone having the same issue?
It is super annoying as I need to deactivate my gsm internet connection and actively connect to this WiFi network in order to use the mobile phone properly.
Maybe I need to load iode fresh and wipe all data once from the phone.

Hi, I suggest you to open an issue at Issues · iode / ota · GitLab and provide a logcat. Maybe this could be solved.

Been having this issue for the last few days myself, but it’s working as of this morning. How about you?

Indeed!!! Now that you say it. It is OK again!!!

This is great but how can this be?
Why is it “just like that” fixed?

Interesting, no?

Best regards

I took a look, and there’s maybe an issue with the NTP server that we use. It may prevent https connectivity test with the captive portal, resulting sometimes in “partial connectivity” and the notification to allow internet. However, I think it should happen only on fresh installations, where the hour is not accurate before the first NTP fix. The NTP server will be changed in next release (ntp.pool.org0.ntp.pool.org), and maybe it could solve your issue, although I doubt about it.


pool.org is not NTP site
Do you mean 0.pool.ntp.org?

oooops :wink:

It was the same on my fp4.

Hope the ntp Adress fix, fixed it at all.

Thx to all here.

Just installed the version 3.0 onto my Galaxy s10 and the wifi iasue is back. I have internet but the signal says no and thus the system is creating some problems.

Any alternative solution next to the NTP server?

Thanks and best regards,

since yesterday I have the same problem, connected to Wifi, but no Internet through this connection. LAN works fine.
My device is a Sony XZ2 and I use iode 2.4 for a couple weeks now, my router is a AVM Fritzbox .
Connects to other router work fine, I deleted to device on the router, restarted both devices several times.

Any idea?

1 Like

Indeed, just checked my old galaxz s9. Same issue.
The phone from my wife - no iode yet - is fine.

Do you have still the same issue with iode v3.0?

I’m still on iode 2.5, there is no official 3.0 for my device