Unofficial build for Google Pixel 7a (lynx) and pre-install images download here:

Build info:

Based on the latest iode July releases it is built for daily use on my own lynx device. It’s a userdebug build signed with test-keys. July security patch.

Bootloader relocking is not supported.

Built following guides from iodeOS and LineageOS


Follow the Lineage OS installation guide and use the pre-install images and rom downloaded from the link above. Factory reset/format data in iode recovery will be required before sideloading the rom.

Restoring data from your previous OS:

Based on my own experiences I would advise a manual restore of any previous data. I have often used Seedvault but find it slightly unreliable plus I suspect it may bring unwanted system settings into your new installation. Going forward I may experiment with the android-backup-project which I have used before with some success on unlocked devices.


The only reason I do this is to be able to run iode on my own unsupported device so their are no guarantees that I will continue to do this going forward. But generally it would be safe to assume I will post new builds here following at least the iodeOS official realease cycle. Updates can be sideloaded from recovery without factory reset thus preserving data.


The usual statements apply. Sometimes things go wrong updating and you may have to factory reset. This could be for any number of reasons and happened to me just recently so have those backups in reserve.

2 Likes and pre-install images download here:

Link removed.Ask in this thread if you want this build.

Works well on my daily lynx device for browser, calls, volte, vowifi, messages etc.

  • August security patch

  • Bootloader unlocked

  • Rooted debugging available in developer options and pre-install images download here:

(Link removed when another build is added)

It’s working great on my daily driver with the exceptions that SafetyNet does not pass and Charging Control does not work.

September security patch.
Lock bootloader is unfortunately not possible.

1 Like and pre-install images download here:

(Link may be removed when another build is added)

Installation Notes:

For first time installing follow the link in the OP of this topic.

For updating it can be sideloaded in recovery without wiping.

An alternative which I have just tested on my device is to use the Local Update option in the device updater (3 dot menu). Hint: Set the option to prioritise update processs in the Preferences if you want the fastest update.

You can also verify the download on device using the downloaded SHA256sum with an app from F-droid such as Hash Droid.

1 Like

This build for lynx is now signed with dev-keys; bootloader locking now supported.

Note: Locking or unlocking the bootloader triggers data wipe. Backups may be required.

Download iode-4.7-20231177-lynx-signed and the pre-install images here:

Link removed

Installation Notes:

For first time installing follow the link in the OP of this topic.

For updating it can be sideloaded in recovery without wiping. At Step 1 on device screen while installing in recovery you will likely get the warning “signature verification failed: recovery: error 21, Install anyway?” Select yes to continue as normal.

The bootloader can now be locked if you like but data will be wiped.

Reboot to fastboot mode, flash the avb key and issue the locking command.

fastboot erase avb_custom_key
fastboot flash avb_custom_key avb_custom_key-lynx.bin
fastboot flashing lock

Working on my now locked device.

Issues I’m aware of: SafetyNet not passing, Charging Control does not work.

1 Like

Thank you for the images.
I have rooted my phone with magisk and I use safetynet-fix. That works. ACC works, too.
Can I backup and restore the whole partitions, to save data while locking the bootloader? What would be the best way? Formerly I used TWRP, but with Lineage Revovery I don’t know, how to to achieve this.

1 Like

I think you have to forget about locking bootloader if you root the phone. That’s not possible. It’s one or the other as far as I know.

It sounds like you have what you want those fixes.

When it comes to backing up you must do your own research into what works for you. Personally I just do everything manually and set the phone up clean when I have to.

But there is a link to an interesting back up method in the original post of this thread. I’ve used it in the past.

Nice to know someone uses the build. :smiley:

@mbrum You’ve probably noticed there is an official build for lynx now.

I’m going to be installing official iode on my phone which makes me consider whether continuing here.

I think you are the only one using this unofficial build, it’s hard to know.

I understand you may not want to wipe your device in order to install the offiicial build, so if that was the case I can continue. But the they would be untested.

Thank you for the information.
I will flash the official one.
Is it really necessary to wipe the phone. Dirty flash with recovery or adb won’t work? Or should I try? I have made a backup.

Oh yes, you have boootloader unlocked. Might work. Worth a try.

Good luck!

It didn’t for me and I got a corrupt device. Hard power off and plugging into fastboot mode was OK where I reflashed as per the LOS instructions (link in OP at top of thread)

EDIT: I seem to be in a bit of a mess with this. Hope you haven’t done yours yet, or it was ok?
Can’t lock bootloader again at the moment so need to sort the other slot out.

What I did:
Tried to update with updater, it didn’t accept the image.
Updated via adb sideload what worked. stopped running (?), the updater couldn’t check for updates, the rest was O.K.
So I decided to do the safe way and did a clean install using the batch file (… still stops running and the updater cannot check for updates. But everything seems to run (as it did with sideload).
And now I am installing and restoring … (Not a nice job, but whom I am telling.)

Same here.

And to get bootloader locking accepted I’m going to try going back to stock and start again.

A wrong version of the AVB custom key has been embedded in the fastboot package, sorry…

The good one is here:

To relock the bootloader:

fastboot erase avb_custom_key
fastboot flash avb_custom_key avb_custom_key-lynx.bin
fastboot flashing lock

All’s well that ends well.

Thanks :smiley: