New iodéOS installer!

Hey all,

We have just released in beta a new program available for linux and windows to install iodéOS in a few clicks! Feel free to test it out and make suggestions :slight_smile:

Bonjour à tous,

Nous venons de sortir en beta un nouveau programme disponible pour linux et windows pour installer iodéOS en quelques clics ! N’hésitez pas à le tester et à nous faire un retour :slight_smile:

Hallo zusammen,

Wir haben gerade ein neues Beta-Programm für Linux und Windows veröffentlicht, um iodéOS mit wenigen Klicks zu installieren! Fühlen Sie sich frei, es zu testen und Vorschläge zu machen :slight_smile:

Great stuff. Is the source code available publicly?

1 Like

Good news…
By …

My FP5 run with /e/OS.

That’s fixed. For various reasons, it should have only concerned FP5. The installer should work for all devices except Samsung ones, although some adjustments may be needed here and there.

I’ve spread the info about the installer in Fairphone and Shiftphone Community

Great news, thanks to anyone who worked on this!
I just tried it out with my fp5 (stock). Unfortunately, (maybe I did something wrong?) after the “successfull” installation, I’m now stuck in Fastboot Mode )-: .
In the very last step, I did not lock the bootloader.
Is there anyone who could give me a hint what to do (or who to ask)? Should I simply restart the installation? If it helps, I copied the details during the installation…
Thanks a lot

Did you try to reboot to recovery ?
If you have more details, this could help.

Hi vince, thanks for your reply! Yes, I tried this also, but it always returns to the fastboot-menu.
I try to attach the screenshots of the details during the installation.
I probably should have shut down the anti-malware-tool on my computer before. When the installation started, it wanted to refuse the execution of two files, in both cases I forced to let the files being executed; then I shut the tool off for the rest of the time. So finally I thought it shouldn’t have bothered the installation.
What was a little surprising to me was that it took some time in the middle of the process telling “waiting for any device”. however, I’m far from being an expert, maybe the screenshots can help.
Thanks a lot for any help.

Installation fails at that point : “fastboot: error: Failed to boot into userspace fastboot”.
After flashing the kernel and a few partitions, the device should automatically reboot to recovery, in the FASTBOOTD mode: apparently, that does not work, and there’s no clue why. Did you touch your device at some point? When installation begins, there’s no need for any user action, except for bootloader relocking.

Thank you for having a look at this.
It might be I touched it, I can’t exclude… can I now do something?
Apart from this, what thus could be a users’ fault, the installer seemed really nice to me. :+1:

If you could not install another system, you cannot use the installer, actually it only works starting with a running system. We’ll add in the future a device detection mode in bootloader.

So what you can do if you’re stuck in bootloader, is to follow the manual installation instructions: iode / ota · GitLab.

Thank you so much. I didn’t want to make everything worse by ‘panically’ muddling through. I will try this. :four_leaf_clover:

I installed iode on my FP5 with and i had a bootloop.
format data helps.
Everything works fine.

How long did you install it ? A partition format was missing (metadata) in an early version of the fastboot package, the last one should be ok regarding this issue.

EDIT: the fastboot package in the beta repo still miss that metadata format…

Thank you for ecouraging me to try the manual installation.
First, this worked fine until the same part as with the installer (so the problem is not the installer).
I get

extracting vendor_boot.img (96 MB) to disk… took 0.274s
archive does not contain ‘vendor_boot.sig’
Sending ‘vendor_boot’ (98304 KB) OKAY [ 2.379s]
Writing ‘vendor_boot’ OKAY [ 0.285s]
archive does not contain ‘vendor_kernel_boot.img’
extracting super_empty.img (0 MB) to disk… took 0.016s
Rebooting into fastboot OKAY [ 0.000s]
< waiting for any device >

But then, it gets stuck (now for about 25 mins).
sorry for asking again :neutral_face:: any ideas?

Sounds like you should try another USB cable and/or port

Oh yes, this kind of reason is always possible even if it seems unlogical as it always worked fine like this in all other moments. Therefore I didn’t think about this yet. I will give it a try tomorrow! Thanks for your idea :slight_smile:

Downloaded the fastboot-zip 25. Dec. 12:00

unfortunately, this helped neither :neutral_face: .
It always gets stucked with this screen,

then, the installation is “waiting for any device”.
It seems the problem is “Failed to boot into userspace fastboot; one or more components might be unbootable”.
I thought I did all preparations as I should before the installation. Or could I have missed something? Has anyone another Idea?

…after having tried it now with another computer (what didn’t even start), I have an idea what I could have messed up. A propos preparations before installing…
Is it possible that this results from not checking here (always allow usb-debugging from this computer), right? With a bit more presence of mind, I would have done this check of course :cry: