IodeOS installation on FP3 failed

Dear community,

I tried to install IodéOS in my FP3 (I did successfully with FP4 bevor) using the installer.
First time installation failed, device was booting in FairphoneOS again.
So I tried a second time. Result: bootloop in Fastboot mode.

I’m not able to install any ROM on my FP3 (neither IodéOS nor FairphoneOS), because “Critical partitions are not unlocked” allthough bootloader is open.

Has anybody an idea for solving my problem? I didn´t find…

Kind regards
Felix

AnotherElk could fix the problem: i used an old version of fastboot!
After updating everything went smooth :slightly_smiling_face:

Hi Felix,

there’s a documentation from Fairphone on how to “manage” the bootloader over there → https://support.fairphone.com/hc/en-us/articles/10492476238865-Manage-the-Bootloader

As I’m having the same issue over here: Do you know where I have to put the latest platform tools so iodé’s autoInstaller finds it? Or dit you install manually? Running on Windows 10 here, btw.

Best,
-k

There may be other reasons for your problems. The iodé installer does not use already installed platform tools. It downloads the latest version for the initial diagnostic, and uses a fastboot version which is compiled when building the ROM.

But I confirm: fastboot installation is broken on FP3. It has been disabled in the installer.

1 Like

Thanks for your answer, Vince! I tried installing it manually but didn’t work, either. Maybe my error log helps:

flash-all.bat
mke2fs 1.46.2 (28-Feb-2021)
Creating filesystem with 12777209 4k blocks and 3194880 inodes
Filesystem UUID: 334362ee-3ec7-11ef-8ae3-e1cb514ffb7d
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424

Allocating group tables: done
Writing inode tables: done
Creating journal (65536 blocks): done
Writing superblocks and filesystem accounting information: done

Sending ‘userdata’ (4661 KB) OKAY [ 0.130s]
Writing ‘userdata’ OKAY [ 0.049s]
Finished. Total time: 0.426s
******** Did you mean to fastboot format this ext4 partition?
Erasing ‘userdata’ OKAY [ 0.235s]
Finished. Total time: 0.266s
Sending ‘modem_INVALID’ (90112 KB) OKAY [ 2.127s]
Writing ‘modem_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed

Bootloader Version…:
Baseband Version…:
Serial Number…: A209FPAR0201

extracting android-info.txt (0 MB) to RAM…
Checking ‘product’ OKAY [ 0.020s]
Setting current slot to ‘INVALID’ FAILED (remote: ‘Invalid slot suffix.’)
fastboot: error: Command failed
Rebooting into fastboot OKAY [ 0.011s]
< waiting for any device >
fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.
Sending ‘aboot_INVALID’ (1646 KB) OKAY [ 0.069s]
Writing ‘aboot_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘cmnlib64_INVALID’ (258 KB) OKAY [ 0.039s]
Writing ‘cmnlib64_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘cmnlib_INVALID’ (200 KB) OKAY [ 0.039s]
Writing ‘cmnlib_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘devcfg_INVALID’ (39 KB) OKAY [ 0.039s]
Writing ‘devcfg_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘dsp_INVALID’ (16384 KB) OKAY [ 0.411s]
Writing ‘dsp_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘keymaster_INVALID’ (312 KB) OKAY [ 0.039s]
Writing ‘keymaster_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘lksecapp_INVALID’ (56 KB) OKAY [ 0.039s]
Writing ‘lksecapp_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘mdtp_INVALID’ (17390 KB) OKAY [ 0.451s]
Writing ‘mdtp_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘rpm_INVALID’ (170 KB) OKAY [ 0.029s]
Writing ‘rpm_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘sbl1_INVALID’ (443 KB) OKAY [ 0.049s]
Writing ‘sbl1_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Sending ‘tz_INVALID’ (1495 KB) OKAY [ 0.069s]
Writing ‘tz_INVALID’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
Rebooting into bootloader OKAY [ 0.008s]
Finished. Total time: 0.009s
OKAY [ 0.075s]
Finished. Total time: 0.079s
Press any key to exit…