iodéOS 2.10 → 2.19 update don't work

Hello, there was a notice for a update on my Teracube 2e. I have clicked install. Download and install and update and reboot runs few hours. After a reboot, there is always the old OS installed and the same notice is displayed. I have run this 2 times. It has no effect.

iodéOS 2.10

Android 11
February 10, 2023
Last checked: February 7, 2024 (23:12)

iodéOS A - 2.19

January 19, 2024
1.1 GB
Install

What is the problem?

Same with me. I have two Teracubes 2e (bought in May '23), one of which could not be updated for a year now (Android 11, iodéOS 2.11). I contacted Antoine for help from iodé but received none. In July I posted a request to the community - no reply either (Teracube 2e - update 2.12 coninuously failes). I was thinking I was the only one with this sort of problem … Tried updating several times, nothing worked, even reset to factory settings failed solving the issue.

Try the following: open “iode news” on your phone, choose “join/participate” (or whatever the Englisch word for “Mitmachen”), then “Become a beta tester” and follow the link (github). Donwload the installer (it replaces the one on your phone). I tried this for one of the two Teracubes and it worked. The phone even got promoted to Android 12 (very nice), iodé is now 3.10. There is a downside, though: Being a beta tester means that some updates may not work properly - one crashed my phone entirely and I lost everything.

But then … since there are now two of us, maybe we get heard in the community! In any case, keep me informed.

Hello bomdomqw1,

today, a update to 2.20 was displayed. I have run the update (download, install, reboot = 6 hours?) without errors or warnings and it is the same: No changes. Still 2.10 is installed.

I had tested to display the boot display. This is very difficult. I had try different key pressing and after a long time the boot display was displayed. I don’t remember me, wich was the correct key press. Then I had choice Fastboot. Then “=> Fastboot …” was displayed and no key press changed this. I must remove the battery.

Its frustrating. No FM Radio. Bad cam. No Updates. No or bad support.

What is your Teracube 2e version?
Serial Number: 2020… = codename “zirconia”
Serial Number: 2021… = codename “emerald”

Works the FM Radio on your Teracube 2e?