Anyone successfully created a build for a tablet?

Dear Community,

I am totally happy with iodeOS!

The only thing I am missing is a supported tablet.

Has anyone been able to create an unofficial build for a tablet?

I have a Galaxy s5e (SM-T725).

Any hints on whether it makes sense to try to build it myself or not would be greatly appreciated.

Thanks in advance and have a nice week-end.

It will need to be a relatively modern device. I spent a long time failing to build for Sony Xperia Z3, Z3 Compact, and Z3 Tablet Compact (released 2014). The builds were succeeding but the Iode & News apps were missing.

Finally we discovered that this is because the Z3 family are arm devices, and the missing apps are only built for arm64.

Apart from that, I can’t be more help. Good luck!

…I am getting an error message complaining about missing keyboard stuff:

[ 99% 217/218] finishing build rules …
build/make/core/ warning: device/samsung/gts4lv/ includes non-existent modules in PRODUCT_P
Offending entries:
build/make/core/ error: Build failed.
00:36:06 ckati failed with: exit status 1

failed to build some targets (01:07 (mm:ss))


Has someone seen this error before and has a hint for me?

The AOSP keyboard is replaced by OpenBoard in iodéOS, but tablet config files had not been modified.
This is done, you can sync the sources again and try to build.

started all over and now breakfast gives me:

fatal: duplicate path hardware/samsung in /media/stephan/fb606504-cd42-47e3-905a-f70eafe380d9/lineage/.repo/manifest.xml

Ignoring this, brunch later gives me:

[ 99% 609/610] finishing build rules …
vendor/lineage/build/tasks/ warning: ***************************************************************
vendor/lineage/build/tasks/ warning: * Using prebuilt kernel binary instead of source *
vendor/lineage/build/tasks/ warning: * THIS IS DEPRECATED, AND IS NOT ADVISED. *
vendor/lineage/build/tasks/ warning: * Please configure your device to download the kernel *
vendor/lineage/build/tasks/ warning: * source repository to kernel/samsung/sdm670
vendor/lineage/build/tasks/ warning: * for more information *
vendor/lineage/build/tasks/ warning: ***************************************************************
FAILED: ninja: ‘out/target/product/gts4lv/kernel’, needed by ‘out/target/product/gts4lv/recovery.img’, missing and no known rule to make it
18:17:07 ninja failed with: exit status 1

failed to build some targets (12:19 (mm:ss))


Sigh… does anyone know how to proceeed?

You really shouldn’t ignore it - that error message means that your repo sync will not have completed successfully, which means you wont have checked out all the projects you need to build successfully.

That would be one explanation for not being able to find the kernel

First thing is to fix the repo sync error. The problem may be in your local manifest, and once you’ve fixed it you may need to rm -rf .repo/manifest* then call repo init again before calling repo sync

I cannot get past this error message.

Starting all over: Initializing according to iode build documentation with

repo init -u -b v4-staging

repo sync finishes indicating success:

Checking out: 100% (1240/1240), done in 4h27m17.038s repo sync has finished successfully.

But later, breakfast gives me same error again:

Syncing dependencies fatal: duplicate path hardware/samsung in /media/stephan/fb606504-cd42-47e3-905a-f70eafe380d9/lineage/.repo/manifest.xml

.repo/local_manifests/roomservice.xml looks like this:

<?xml version="1.0" encoding="UTF-8"?> <manifest> <project path="device/samsung/gts4lv" remote="github" name="LineageOS/android_device_samsung_gts4lv" revision="lineage-20" /> <project path="device/samsung/gts4lv-common" remote="github" name="LineageOS/android_device_samsung_gts4lv-common" revision="lineage-20" /> <project path="hardware/samsung" remote="github" name="LineageOS/android_hardware_samsung" revision="lineage-20" /> <project path="kernel/samsung/sdm670" remote="github" name="LineageOS/android_kernel_samsung_sdm670" revision="lineage-20" /> </manifest>

I am a beginner building myself - which things should I check to get this going?

I don’t know, I’m new to all of this also and I’m not familiar with samsung either. I assume you have checked (as I have just done) the actual github pages for the four entries in the roomservice xml. Can’t see anything obvious there.

If your .repo/manifest.xml is the same as mine for lynx it will contain just one entry: include name=“default.xml” /.

Have you checked the default.xml in the .repo/manifests folder?

To be honest I don’t quite know what to look for apart from the clue in your error message, i.e. duplicate path hardware/samsung.

Checked the files and diretories for entries that might lead to the cause of the error message. In addition to the entroes in roomservice xml mentioned above found the following:

manifests/default.xml: <project path="hardware/samsung/nfc" name="platform/hardware/samsung/nfc" groups="pdk" remote="aosp" />

manifests/snippets/iode.xml: <project name="LineageOS/android_hardware_samsung" path="hardware/samsung" revision="lineage-20" /> manifests/snippets/iode.xml: <project name="lineage/device_samsung_slsi_sepolicy" path="device/samsung_slsi/sepolicy" remote="iode" />

manifest.xml only contains the reference to deafult.xml so it seems to be the same.

Right now, I do not see the duplicate yet…?

***Edit: I commented out the following entry:

manifests/snippets/iode.xml: <project name="LineageOS/android_hardware_samsung" path="hardware/samsung" revision="lineage-20" />

Now it is downloading the Kernel so it seems like I am making progress - keep your fingers crossed :slightly_smiling_face:

…now I am getting:

[ 63% 98898/156194] Verifying uses-libraries: external/chromium-webview/prebuilt/arm64/webview.apk FAILED: out/target/common/obj/APPS/webview_intermediates/enforce_uses_libraries.status /bin/bash -c "(rm -f out/target/common/obj/APPS/webview_intermediates/enforce_uses_libraries.status ) && (build/soong/scripts/  --enforce-uses-libraries 	  --enforce-uses-libraries-status out/target/common/obj/APPS/webview_intermediates/enforce_uses_libraries.status 	 
 --aapt out/host/linux-x86/bin/aapt 	   	   	   	   --enforce-uses-libraries-relax 	  external/chromium-webview/prebuilt/arm64/webview.apk )" zipro W 08-20 12:40:20 651818 651818] Error opening archive external/chromium-webview/prebuilt/arm64/webview.apk: Invalid file 

ERROR: dump failed because no AndroidManifest.xml found
error: Command '['out/host/linux-x86/bin/aapt', 'dump', 'badging', 'external/chromium-webview/prebuilt/arm64/webview.apk']' returned non-zero exit status 1
12:40:23 ninja failed with: exit status 1

#### failed to build some targets (01:51:07 (hh:mm:ss)) ####`

Is this a “Sources not up-to-date” issue or do I have a chance to solve this?

Check this out and use the command suggested by Vincent.

I finally managed to get the build process to complete successfully and am now a very happy iodeOS tablet user!

Of course, everything is working as expected.

Many thanks to all community members that helped me to get through this.