Update of Aurora Store doesn't work

a couple of days ago i checked Aurora Store if there are some apps to update, and a little popup appeared saying that there is an update of Aurora to version 4.4.1.

Currently installed: 4.3.5
Device: Samsung A52s on iode 4.9

I can either ignore the update or apply it - but updating simply doesn’t work. The self-update runs in the background (at least it says so), but fails to install. With the next start of Aurora the process starts again, and again, and…

Interestingly: i was able to update one app (outdooractive), but i’m not able to update Whatsapp or Magic Earth.

Is this a known error? Has someone else had this problem?

iodé aurora fork (4.4.1) was released on f-droid february, 12th.
Have you checked your f-droid updates?

yeah, checked them - no update available in f-droid.

I had the same issue. AFAIK updating Aurora Store is only possible over f-droid store. Over f-droid the update worked for me. Maybe you have to wait a little bit until the update appears.

Does WhatsApp and Magic Earth stay in “Queued”-mode? So is the loading bar loading and loading, but nothing happens? I had that problem, too. It fixed itself a few days after it first appeared. May be some sort of rate limiting of Google or so.

Hehe, now it worked. No updates when starting f-droid, but when wiping down in the middle of the tasks-screen the package sources are updated, and … heeeere are the updates.

Well, f-droid should check daily for updates, not sure why it didn’t.