Unofficial build for Sony Xperia ZX1 Compact (lilac)

The fix was to add the following line to prebuilts/FDroid/

Looking at the latest in gitlab, that line is not present

I have re-synced the repo in my build tree, and it’s not there either :frowning: Am I missing something very basic?

Hum. Here it is, now.

1 Like

Ok I re-flashed it and this time it worked without the need to disable the privileged extensions in f-droid

1 Like

Here’s a new build Built from the v4-staging tag

Available from AndroidFIleHost

I have tried clean flash, and dirty flash over iode-4.0-20230221-lilac: both seem to work OK. But as always, if you are going to dirty flash, then I would advise backing up your current setup (using Android Backup and Restore Tools project. This is a user-debug build so rroted debugging is supported)

Feedback welcome. Have fun!

I have done a dirty flash since I don’t really know how to backup my apps.
I will try to understand Android Backup and Restore Tools project but I really don’t have time right now to do so, so I stick with backup from TWRP just in case.
Anyway I’ve been using IodéOS for one week and I like it very much actually. Thanks a lot.
Today (before the update and after also), I had the issue with F-Droid and the offer to update microG services core and also FakeStore (iodéOS version of microG Fakestore) but that failed. I did what you said (ignore this update).

Thanks again if I see other problems I’ll tell you

Here’s a new build.

It fixes the signing problems documented in this issue and this post

Clean flash, and dirty flash over the previous version both seem to work OK

I’ve done a dirty flash and same as before for the update of microG services core and FakeStore. “Error-7” unable to do the update

:frowning: Sorry about that. It may be that backup, clean flash, restore is the only way to get round this one.

There may be some magic that can be done with adb or adb shell to get rid of the badly signed microG services core and FakeStore. I’ll have to have a play. Or you can learn how to drive Android Backup & Restore :slight_smile:

Well I did a clean flash and it worked. But I had to reinstall everything since I couldn’t restore my apps data, I tried to do it with TWRP but apparently I messed up. I don’t really understand how it works so…
Anyway one day I’ll learn and it will be easier but the update on fakestore mircog etc… worked this time

TWRP backup hasn’t worked well for me since Android Q or R. Android Backup & Restore tools really is the way to go

I wrote a short ‘how to’ post in the /e/ forums for someone who thought it might be too complicated. (It really isn’t :slight_smile: )

1 Like

Thanks a lot, I 'll try it next time

Hi there,

I tried to run the android-backup-project-v2.1 but I have this comming on the terminal :

Capture d’écran_2023-04-07_18-21-09

I don’t know if you know what to do ? Anyway I’m stuck for the moment…

The backup and restore scripts use the [git source code version control program]( and some others. The first thing it does is to check those programs are installed. If they are not, it shows an error message. git isn;t installed on your machine, so you need to install it.

How to install programs depends on what Linux distro you are running. For Debian-based distros (Ubuntu, Mint, Debian) the command sudo apt install git should work.

If other required programs are missing, you will see a similar message, and you need to install the program in the same way you installed git

Ok thanks a lot again

It worked thanks a lot. But it just backup and restored my apps, not the configuration of them.
And do you know how you can backup and restore your system configuration ?

I’m not sure what you mean by configuration. The tools will usually back up and data and settings that the app manages for itself.

Things it doesn’t back up often include account information like username and passwords for online accounts. With some apps (e.g. K-9 Mail, QKSMS), you can export or backup the data within the apps (Account usernames and settings, SMS messages), and import or restore it after you have restored your backed up apps.

Another thing that doesn’t get backed up is username and passwords for cloud accounts like NextCloud (or eCloud/ and DAVx5 accounts you will have to re-enter these manually.

I use Lawnchair 2 as my Home screen / Launcher app, and it allows you to backup all your homescreen settings. Not all launchers allow that, so you might end up having to set that up from scratch if the tools don’t restore it.

Sorry, french word.
I meant settings, I think, like : light or dark themes, no sound when I hit the keys or turn off the screen, wallpaper etc…
Thank you for your answer.
Maybe I’ll try Lawnchair 2. I’m on trebuchet the default app.

Hi and thanks for the continued work on this device…
Will VoLTE and Wifi calling work?
Also, does adoptable storage work (extending internal storage with sd card)?

It depends on your carrier. I am with an MNVO using EE UK network, and both VoLTE and Wifi Calling work for me.

I have not tried. Current advice is that it may cause problems. I want/need my SD card to be portable between devices.

Thanks thats good info.

Are there specific issued with adoptable storage?