Text-to-Speech

Hi,

it seems that text-to-speech (ttf) is no longer part of LineageOS (and iodé). As a result, voice messages do not work when using e,g, OsmAnd for navigation. Is there a chance to add a useful ttf engine to iodé?

Thanks & Regards
Tom

Hi,
We have looked text-to-speech alternatives in the past but haven’t found any satisfying ones to integrate into iodé.
Suggestions are welcome if anyone has one alternative to share with us

Regards,

Hi Antoine

the best suggestion I found so far, is Vocalizer from CodeFactory.
https://codefactoryglobal.com/app-store/vocalizer-expressive-android

Under the following URL you can get an impression of the quality of Vocalizer:
https://codefactoryglobal.com/speech-technology

Unfortunately, I was not able to successfully install it, so far.

Regards
Tom

eSpeak App Screenshots

App eSpeak version 1.51 dev works on all devices with DivestOS 18.1 (an unofficial soft fork of LineageOS 18.1).

I downloaded it but I was not able to install voice files from the SD. Whenever I try, it just does nothing.

For successful remote help, it always makes sense to specify device and OS version.

I’ve now installed eSpeak on a Galaxy S9 ‘starlte’ with iode-2.1-20210828 as the system app. The typed text is spoken with the system language. Setting the voice, male, female, other language, etc. -it works.

Sorry, you are absolutely right. I am on a FP3 with iode-2.1-20210828. I have installed eSpeak from f-droid. I got the voices from mbrola. I downloaded all 7 de-packages and put them into the root directory of the SD-card because when I open the eSpeak app I can only choose to install it from SD-card. There is a drop-down arrow next to the choice “Import from SD-card” but when I click on it, it does nothing. When I click OK, the dialog closes and nothing seems to happen. I can set voices now inside eSpeak’s settings. When I type some text I can hear a very strange voice (sounds like from science-fiction films of the 80’s) speaking the text, but choosing another voice does not yield any effect. From the system settings I can only get a voice when I set the language explicitely to german, system language greys out the button for testing. If I however choose german explicitely, I get the same science-fiction voice that I get inside eSpeak’s settings.