Spell correction doesn't work

Information from the Iode.tech says that The keyboard (OpenBoard) supports spell correction, but my keyboard doesn’t for some reason.

Spell checker is On but it’s not working. It seems that there are no necessary dictionaries.

I have another phone and there is a menu item ‘Add-on dictionaries’ (Language & input → Keyboard Settings → Text correction → Add-on dictionaries), so there is no ‘Add-on dictionaries’ on my Samsung s10e running Iode 3.5-20230131-beyond0lte.

Please tell me how to download the necessary dictionaries for the spell correction to work.
Thank you!

Openboard works ok on my phones. No add on dictionaries required.Do you not get word suggestions at the top of the keyboard when you are typing?

Have you selected your language in System, Languages and input, scroll down to tools, select Spell Checker, select Languages and choose.

Add-on dictionary isn’t required only for English, German, French, Italian and Spanish, add-on dictionaries are required for other languages for spell correction to work.

Here’s how it looks on my old phone:

There is no such menu item as “Add-on dictionaries” in IodeOS.

I assume that It’s a bit like with text-to-speech (TTS) which is also not in IodeOS. I’ve downloaded and installed TTS from the Aurora Store, but I don’t know how to download the dictionaries for spell correction.

No, definitely not
Openboard work as expected with all languages for me

Try Catala, or Afrikaans, or Indonesia, for example.

I was curious and tried these yesterday . Bit difficult for me as I don’t know anything in those languages! But yes, I see the problem now.

Anyway, had a bit of progress. More like word suggestion rather than spell-checking maybe. Maybe you know all this and I have got the wrong end of the stick!!

To my system language of English I added Afrikaans. To Openboard app preferences I made sure the languages switch key was toggled on. Seemed to need a restart to make it work, not sure.

With a copy of some Afrikaans text and translation I tried some typing and mistyping and the word suggestions seemed to get better as I went on.

In the screenshot below each word in the last line was entered as a result of slightly mistyping and selecting the word suggestion.

By the way, in the fdroid information for the app under Links > Source code there is a link to their community matrix channel.

1 Like

Let’s define what can be called a spell checker that works.

  1. When I type the word ‘Speling’ in English and hit the space bar, the word is automatically replaced by ‘Spelling’.
  2. If I remove the space, the word reverts to the incorrect ‘Speling’ and it’s underlined with a red line.
  3. If I type something obscure like ‘fhhftygg’ it is underlined with a red line.
  4. Also, if I just start typing a new word, three word suggestions appear above the keyboard.

If I understand correctly, you have the fourth item working with the Afrikaans language, right? It’s interesting because I can’t reproduce it.

I currently have a spell checker that works for the following languages:
English, Bulgarian, Danish, Dutch, French, Deutsch, Greek, Hungarian, Italian, Polish, Portuguese, Romanian, Spanish, Swedish, Turkish,

Only the 1st and 4th items of the list work for the following languages:
Bangla, Esperanto.

@chrisrg could you please go to Languages & input → On-screen keyboard → OpenBoard → Languages and add Ukrainian language? Then open notepad and type ‘Піснч’. Don’t copy and paste! It may seem a little difficult if you are not familiar with the Cyrillic alphabet, but I’m sure you will succeed. Then hit the space bar. Has the word changed to the word ‘Пісня’? Then type something obscure like ‘рітґємїк’. Is this word underlined with a red line?

And yes, you are right, it is worth contacting the developers of this application. Although the app works fine on my other phone, there is an option to download additional dictionaries to make the spell correction work.

OK, good.

No, not really. by the time I got to the last line the keyboard had learnt the words from my previous correct typing.

No, it’s not working. I tried it another phone (with iodé also), added ukrainian to openboard, never typing the correct word: no word suggestion or red lines.

The app on your other phone is openboard? Older version? and the add-on dictionaries are in the openboard settings? I tried to downgrade the keyboard but it won’t do it.

1 Like

since today i’m experimenting with the original google keyboard gboard.
install the lite version of apkmirror (it’s trustworthy, the androidpolice team is behind it), then configure the desired languages, use the gboard once in the languages ​​so that the dictionaries are downloaded, and then via the app settings or the iode blocker withdraw the network connections from the app so that it can no longer connect to google.
disable openboard in the keyboard settings, otherwise the gboard will not work properly.
also works without any problems in the shelter profile
maybe you will have fewer problems with the spell check in your languages. try it.


1 Like

Does that setup support speech to text? Or is netwrok connection needed for that?

Don’t know, do not use such things
Has to be checked from somebody

It turns out not, it looks and works exactly the same (except for the possibility to download additional dictionaries), but it’s not OpenBoard. My mistake. My old phone has AOSP installed on which OpenBoard is based.

I have already created a report about the lack of necessary dictionaries on the OpenBoard account on GitHub. Hopefully this will be implemented in future updates.

Thanks for your support Chris, you’ve helped me a lot!

1 Like

This is a good idea and an alternative, thanks!)