Sony XZ2 lost MAGISK after update to 3.2

Hi,
the update to 3.2 worked fine, but as last time, root access via Magisk was gone.
Last time, reinstall of Magisk worked, this time, it doesn’t and I don’t know what is wrong.
Since Magisk isn’t signed, it can’t be installed via IODE recovery and adb.
Last time I used the Lineage 19 recovery, since it is possible to install unsigned archives.
What I tried:
as root:

fastboot boot ./lineage-19.1-20221019-recovery-akari.img
Sending ‘boot.img’ (65536 KB) OKAY [ 2.241s]
Booting FAILED (Status read failed (No such device))
fastboot: error: Command failed

the phone is/was visible with fastboot devices

next try:

fastboot flash boot_a lineage-19.1-20221019-recovery-akari.img

Works, I can flash magisk via ADB sideload, but iode won’t start anymore.

So, next step:

fastboot flash boot_a iode-3.2-20221014-akari-recovery.img

I’m back from where I started, since the patched boot image is overwritten.

Where is my mistake?

thanks
Uwe

I finally got Magisk installed.
This time, I patched the iode recovery image with Magisk.
Steps:

  • copy the file iode-3.2-20221014-akari-recovery.img from PC to the phone.
  • In the Magisk app, choose install and select the iode recovery file, after the patch, there is a file called magisk_patched-25200_UNfNB.img. Copy this file to the PC.
  • Boot the phone in Bootlaoder mode, with the extended shutdown menu in iode or via

adb reboot bootloader

The phone restarts and the blue LED is on.
Check for the fastboot connection with fastboot devices.

  • If the phone ist visible, enter

fastboot flash boot ./magisk_patched-25200_UnfNB.img

and restart the phone, now iode is patched and Magisk works