[solved] Adb looses track of device while installing iodé on FP4

Hello there, ty for making as well an attractive community forum :slight_smile:

Am trying to give iodéOS a shot on my brand new Fairphone 4 using iode / ota · GitLab guide, but keep running into a (possibly non documented) blocking issue after step 4. btw you may treat me a newbie regarding Android stuff, though less on Linux which is my driver for 2 decades. Updated Arch linux OS used on the PC.

Device is a Fairphone 4 updated to Build: FP4.FP4I.A.091.20221207
[x] USB Debug
[x] Bootloader unlocked (rebooting to bootloader : « DEVICE STATE - unlocked)
SIM card still in place (maybe better if I remove it?)

iodéOS 3.4 downloaded + verified from Release iodéOS 3.x for Fairphone FP4 · iodeOS/ota · GitHub

adb devices listed my FP4 before I did:

$ adb reboot bootloader
$ fastboot flashing unlock
OKAY [  0.035s]
Finished. Total time: 0.035s
$ fastboot flash recovery_a iode-3.4-20221215-FP4-recovery.img
< waiting for any device >
^C

Note that stock OS started to boot before I finished entering the ‘fastboot flash recovery’ command. I proceeded nonetheless but had to interrupt the process after 2+ minutes without any output. Now adb devices doesn’t list my FP4, and still doesn’t after trying 9-10 times (even from stock Android), un/replugging the USB cable.

At which point your advice, ideas would be kindly appreciated when possible.

Got it.
fastboot flashing unlock had my FP4 reboot to FP’s stock Android OS before I could finish typing the next command, loosing the USB debugging setting I just made. Since it was the same OS / environment, it took me some time to realize. Re-enabling USB debugging allowed me to proceed.

Unlocking and relocking the bootloader ever ends in a factory reset and so all settings done before are lost and have to be done again