Signal app in iode' 2.0

Weeks ago I installed the signal app to send text messages. I’m using iode’ 2.0 from a Sony Xperia XZ1. I’ve noticed that at times it has trouble sending simple messages to 1 person. What I do is switch over to the textra app which I also have installed for texting and the same message and single recipient sends.

Any ideas why?


Does VoLTE and VoWiFi work? Your issue can be caused by lack of support for IMS services if an app needs this to communicate SMS. I have seen similar issues on a S9 without IMS support due to Samsung proprietary IMS that can’t be ported to LOS. I have the same issue in my XZ3, no IMS so defaults to 2G or 3G bands that are spotty and will soon be turned off, big problem I hope get fixed.

I usually use the unofficial version of Signal Messenger called Langis instead of the original Signal app:

Langis: Signal without Google Play Services support, Signal sans Google Play Services.

The Langis app works well up to Android 10 > LineageOS 17.1 including automatic update when integrated into the F-Droid repository. On devices with Android 11 (and 12) also LineageOS 18.1 as well as iodéOS 2.0 I can’t even install it. I get this error message: »Thered was a problem while parsing the package.«

I just installed Langis on a Samsung Galaxy A5 2017 with iodéOS 1.3. Whether it also struggles with the above issue, I can not say at the moment.

I see from reading some of your other posts that VoLTE is something that you have been looking at and is working on some iode’ phones and not others. On my Sony Xperia running iode’ 2.0 it is not enabled. I dialed * # * # 4636 # * # * and went in phone settings to get this:

I searched around and found some sites saying that the Sony Xperia XZ1 does use Qualcomm and following the link you provided they have a flashable file to enable VoLTE.

Have you tried this in iode’? If so, with which phone?


I backed everything up and tried it. I had to flash that file twice to get it to work…flashing from internal memory with TWRP didn’t give an error. I still don’t have VoLTE working, though.


Thanks for reply. So no VoLTE on XZ1 and XZ3 :slightly_frowning_face:. This is bad news. I hope @Antoine can clarify if or when this will come into focus.

I think I do need VoLTE working as my cell provider (Ting) sent me an email last year and said I would need that this year as they drop the older tech on cell towers.


I’m not sure about this. @vince31fr will take a look at it when he has time