`sepolicy` build error building 4.3 for lilac

Building for lilac-userdebug, which uses the android_device_sony_yoshino-common repo, also used by ‘poplar’. I am getting the following error

[ 57% 90150/156651] //system/sepolicy:recovery_sepolicy.cil Building cil for recovery_sepolicy.cil [
FAILED: out/soong/.intermediates/system/sepolicy/recovery_sepolicy.cil/android_common/recovery_sepolicy.cil
out/host/linux-x86/bin/checkpolicy -C -M -c 30 -o out/soong/.intermediates/system/sepolicy/recovery_sepolicy.cil/android_common/recovery_sepolicy.cil out/soong/.intermediates/system/sepolicy/recovery_sepolicy.conf/android_common/recovery_sepolicy.conf # hash of input list: a316674d1dc0868a105f79e687a4b6449e6a8801cfa3253b9c426787c1c40d09
device/qcom/sepolicy-legacy-um/legacy/vendor/test/genfs_contexts:30:ERROR 'duplicate entry for genfs entry (debugfs, /regmap)' at token 'genfscon' on line 136304:
genfscon debugfs /asoc u:object_r:qti_debugfs:s0
genfscon debugfs /regmap u:object_r:qti_debugfs:s0
checkpolicy:  error(s) encountered while parsing configuration

This looks like it is related to this commit , authored, by @vince31fr .

I tried using the parent commit, but no joy - I get the same error. So I have no idea how to go about fixing this. Can anyone help?


EDIT: I successfully made a userdebug build of lineageso4microg, yesterday, so it looks like the error is related to IodéOS

The culprit file mention in your log snippet ( device/qcom/sepolicy-legacy-um/legacy/vendor/test/genfs_contexts) does not exist in iodéOS repo: legacy/vendor/test · v4-staging · iode / os / public / lineage / device_qcom_sepolicy-legacy-um · GitLab.
Your repo may not be synced with the right repo/branch.

Thanks. After I posted I completely removed the build directory and started from scratch. I susoect that will clear the problem