S9 with iodé4.9: Ongoing WLAN problems

Dear All,

since I upgraded my S9 from iodéOS 2.15 to iodéOS 4.7/8/9 I am facing ongoing problems with the internet access per WLAN. I am running my S9 in addition to iodéOS also with Magisk and AF Wall+ and I establish a connection to my router (FritzBox 7520) only as needed. So, most of the time the WLAN of my S9 is disabled. Typically, I enable and disable it 3-6 times per day.

The problem that I am facing is, that the internet access per WLAN becomes very slow 90h-150h (4-6 days) after a system start (reboot). So, although the WLAN symbol is quickly shown in the notification bar after enabling WLAN, it is not possible to establish an internet connection in order to check my emails (K9), updates of apps (F-Droid, Aurora Store) or the weather forecast (omWeather).

So far I have run quite a number of tests in order find the root cause:

  • enabled/disabled (installed/uninstalled) Magisk and AF Wall+ w/o any improvement
  • enabled/disabled iodè app w/o any improvement
  • rebooted my router w/o any improvement
  • checked my router for unsupported WLAN protocols w/o any improvement
  • checked for strong other WLAN traffic w/o any improvement
  • operated my S9 both 20m away and 20cm away from the router w/o any improvement
  • tried to find a correlation between 2.4Ghz and 5Ghz connections w/o any improvement
  • checked the battery management for disabling apps to safe power w/o any improvement
  • used an arbitrary MAC address as well as the S9 MAC address for WLAN w/o any improvement

On the other hand I have found out:

  • Mobile internet access is not affected. It is always fast.
  • The internet access per WLAN can be immediately improved by restarting (rebooting) my S9.
  • And, I never had this problem when running iodéOS 2.15.

So, to me this in is a problem that was introduced by the upgrade from iodéOS 2.15 (Android 11) to iodéOS 4.7/8/9 (Android 13). I have searched the internet for reports about similar issues and found a number of complaints all related to Android 13. So, currently I assume that it is probably a problem of Android 13.

If you have any idea, how to fix this problem or find a lasting solution (other than buying a new or refurbished Smartphone and installing iodé 2.15 :wink:) please let me know. Your help is highly appreciated.


So I also use the S9 with iode 4.9 beta… and have no problems with the WiFi.
I also use personalDNS…sometimes I have to restart pDNS when I connect to the WiFi…because otherwise it won’t connect…maybe it’s AFwall

Thanks sts61,

I have already ruled out AFWall+ by running a test w/o Magisk and AFWall+ (see my original post). Moreover, when enabled I use AFWall+ not only to control WLAN but also mobile internet access. And the latter was never affected. So, there must be another root cause. :frowning:


In order to narrow down the root cause of my aforementioned problem, I bought a second refurbished S9 and installed the nightly lineage-20.0-2024-04-14. I found that this nightly suffers from the same problem as iodè4.x. So, the issue is not related to a specific S9 and it is not related to iodè4.x but to lineage-20.0. I was further able to track it down to the DNS. I am running a WLAN router with native IPv6 connection and an IPv4 tunnel. It turned out that 4-5 days after booting the system, IPv6 internet addresses were no longer resolved. As a result e.g. k9 tried 4 different IPv6 addresses until timeout was reached before the corresponding IPv4 address was sucessfully used. This resulted in a time delay of several minutes until email was fetched from the server of my private email provider. Another email provider that I use for business emails with k9 offers only an IPv4 address and allows to fetch emails within seconds even 4-5 days after booting the system. Also other apps are affected, e.g. omWeather. So, this rules out also the apps used on my S9.

In order to work around this problem for the time being I have now backed up my apps data, re-installed the most recent S9 firmware from scratch (including factory reset and wipe), installed iodè2.15 and restored the apps data afterwards. Since then, the aformentioned problem did not recur, which also rules out my router as root cause of the issue.

So, for the time being I will continue to run iodè2.15 and ignore any lineage-20.0 and iodè4 update hoping for lineage-21.0 and iodè5. Some of you may have already noticed that an inoffical lineageOS 21.0 is already available.