Removing preinstalled system apps corrupts the app

I tried to remove F-Droid and AuroraStore using the Apps > Preinstalled apps functionality. (This is because I wanted to use the original apps, instead of the ones forked by Iodé, as explained here.)

All worked fine and I could enjoy the original apps of both app stores, but to my surprise, suddenly both apps disappeared. They are not in the app list, nor in the system app list. When I try to reinstall them (by direct download/sideload) it gives the error “App not installed as package appears to be invalid”.

I tried to add the apps again via Apps > Preinstalled apps, to no avail. Now however I get the message “App installed” after attempting an install. However, it still does not show up anywhere.

This is on a Fairphone 5 with a freshly installed Iodé on it, rooted with Magisk and LSPosed framework (only with ACC module, which I installed because the battery limiting charge functionality is not available in Iodé, unlike in Fairphone OS).

I don’t even know where to begin to investigate this. It’s a very weird problem. Unless someone can give me a hint, I will have no choice but to start over and reset the phone.

“because the function for limiting the battery charge is not available in Iodé”

In my Sony XA2 with current iodé, the limitation can be set under Settings-Battery-charge control

The app removing mechanism of iodéOS conflicts with Magisk, which is not supported.

So you cannot have Magisk installed when you remove system apps with IodéOS?

(Thanks for you reply BTW, although I reset the phone since. It’s good to know though, also for others, if there are any incompatibilities with Magisk.)

I suppose, although it may depend on various factors (Magisk version, device, …). The reason, I think, is that they are both based on bind mount techniques.

Well, I am running iodéOS 4.8 with Magisk 26.4 on my S9 and have removed the following system apps:

  • p=p
  • Magic Earth
  • Music, Open Camera, Rekorder
  • Carnet, Kalender, PDF Viewer Plus, Rechner, Uhr
  • Geometric Weather

I have not tried to remove F-Droid or Aurora Store, though. So far, I do not see any obvious side-effect on my S9.