No internet with VPN on Mi 9 [iodé 3.5][cepheus]

After updating to 3.5 I am unable to connect to the internet via VPN.
Directly works fine.
I have tried multiple VPN providers, and multiple VPN protocols (wireguard, openvpn).
It is not a DNS problem, as connecting to the IP address directly does not work either.
I had no issues with 3.4.

I cannot replicate. Please first ensure that VPN is not forbidden in Android settings (app info for apps), or in iodé blocker.

VPN is not blocked in app settings or iodé blocker.
I tried dirty flashing 3.4, but got a bootloop.
When I dirty flashed 3.5 back on the problem was still there.
Is there any way of making a full backup on iodé? (Apps, app data, personal files, etc.)
Or maybe a way to unencrypt the data partition?


Have you testet with deactivated “Block Connection without VPN” and restart device?

Yes. I have tried every different configuration I could think of, and reset multiple times.

I think I’m going to root it and use backup scripts to backup, then try a clean flash.
Does anyone know if just wiping data will be enough? Or will I need to flash MIUI again first?


I wiped the phone and flashed MIUI 12.5.6(china), then flashed iode back on.
VPN worked initially, but when I wiped the data and restored from seedvault the problem was back again.
I will have to start from scratch.
Thanks again for everyone’s help.

Ok so there’s clearly something wrong in your data. If it’s not too late, you could also grab logs and open an issue on gitlab.

Problem was solved after updating to 4.x
Thanks for everyone’s help.