Need Help with Auto-Rotation and Rotation Vector Sensor Issue on Fairphone 4

Hello guys,

I recently installed Iode OS on my Fairphone 4, and I’ve encountered an issues that I could use some help with. The auto-rotation function doesn’t seem to be working anymore. I tested a little bit. When I tried using a compass app, it informed me that the “rotation vector sensor” is not available.

Here’s a bit more detail:

Auto-Rotation Issue:
    The auto-rotation feature, which switches the screen orientation, seems to be non-functional since I installed Iode OS. I've checked the settings, and the option for "Auto-Rotate" is enabled.

Rotation Vector Sensor Issue:
    When I tested a compass app, it displayed an error message indicating that the "rotation vector sensor" is not available. This concerns me because it seems like the sensor might not be working as it should.

I’ve already tried some basic troubleshooting steps, such as rebooting the phone and checking for software updates, but the issues persist. I’m hoping that someone in this community might have some insights or suggestions on how to resolve these problems.

If you’ve encountered similar issues or have any knowledge of potential fixes or workarounds, please share your experiences and recommendations. Your help would be greatly appreciated!

Thank you in advance for your assistance.

Best regards,

Hi Marcel, I can’t be much help but there is an app in F-droid called Sensors Sandbox that can do a live check if its working. It’s old but does work.

Actually a recent app: Phyphox in F-droid. Select Gyroscope test for rotation data.

Hi folks,

I have exactly the same problem with my FP4. Neither the rotation, nor the proximity sensor, nor the light sensor works. I had installed /e/os a few days ago. There I had exactly the same problems. Therefore I assume that this must be a problem of Lineage OS. Iodè and /e/ happen on it.
All sensors work with Ubuntu Touch.
A workaround would be fantastic and absolutely necessary. Especially since I also pay for Iodè. A fix should come soon! :slight_smile:

Translated with (free version)