microG missing permissions

Hi, I’m using iodeOS for a week now and it’s great, however there is one problem that I have.
microG doesn’t have all the permissions that it needs, I can’t five access to sms and gps in background. I already tried to reinstall it but I still got to give the permissions manualy, which is not possible. If somebody has a solution or an idea it would be great if they could share it :smiley:

Did you do the selftest in microG app?
If there are any permissions missing it will tell you and give you the option to set the permissions.
all checkboxes should be checked automatically

Yes, selftest done, i also clicked on the checkboxes that were not checked but I can’t give the permission to get gps in background, not even if I enter the settings and try to do it from there, it just tells me microG is a location provider and therefore I gotta do it from the location settings, but if I go there it puts me back to the same place with the same notification, go to the location settings…

I had the chance to try this on another Fairphone 4 today, as it seems microG just takes the permissions and works when you do a fresh install with microG or after an update. However I don’t have an update and I really would like to avoid resetting my phone again. Is there maybe a possibility to update from the latest to the latest version? I remember lineage was somehow able to do it, altought it always seemed more like a bug that this feature was available.

I’ve never heard from any iode fp4 user from such problems.
And I think this can only fixed with the help of the devs

Just to be sure:

  1. Have you checked to install MicroG (core and framework Proxy) and the other location providers during setup process or not?
  2. How did you try to reinstall it? via settings/apps/pre-installed apps? Or manual via f-droid?
  3. you check the checkboxes in microG selftest to grant permissions, but this didn’t work and you have still unchecked boxes?

I think, you have to decide:
Have a system without microG then uncheck everything during setup process, or with microG then check all.
If you have decided not to use microG at the beginning and you want to have it later, then I would go via /system/apps/pre-installed apps and select all microG stuff there. But not manually any other way.

  1. I tried various combinations, reinstalling all of the microG packages was one of them. I also tried to restart after giving the permissions, but that did not change anything.
  2. I only tried to reinstall it via pre-installed apps.
  3. Exactly, one is GPS in the background and the other one is for SMS.
    I tried to add them later on like you said but it doesn’t seem to work :confused:
    However, I found out that for some reason it works after an update, so if there is a way to reinstall the latest version in form of an update, although having it installed already, that could solve my problems, I guess.