List of models supported

I wanted to try IodeOS on a Sony Xperia XZ2 . After flashing a different firmware so that I have Android 10 when trying to install Iode OS it didn’t work (tried Windows 11 and Linux) - forgot the error. I tried also using the installer but I got an error that my phone model is not supported. Phone is H8216.
Where can I see which models are supported? I wasn’t able to find this list.
Thank you.


Whats the codename?

The code name is akari. The model is on the list of supported models here: iodéOS installation - iodé
I tried to install
Most of the phones have many variants. In case of XZ2 they are: H8266, H8216, H8296, H8276, 702SO, SOV37
Most of them (all expect SO ones) are supported by Lineage OS and other OSes; /e/ OS surely supports my H8216: Info about Sony Xperia XZ2 - akari

OK @petefoth is our Sony specialist
Maybe he can answer

my device is a H8216 Akari and iode 4.10 runs good. The installation was no problem, I came from Lineageos to iode

XZ2 akari is a bit too modern (and too big) for me :smile:

Best place to look for supported models is the LineageOS Devices Wiki page for the device (because IodéOS is built on LineageOS code).

For Sony, devices with SO in the model number are usually from the far east market (China, Hong Kong, Singapore), and are usually different enough from the standard models that custom ROMs for standard models will either not work at all, or will partly work but with important functionality missing or buggy.

If the IodéOS installer for XZ2 doesn’t work on your device, then I guess that the different firmware you installed is what is causing the problem. I can only suggest installing the correct firmware by reflashing the stock ROM. But I generally dont mess with firmware - becasue I like my devices to work :wink: - so this is mostly beyond my knowledge and experience. Good luck!

Thank you for your replies. I installed the Orange FR-ES-PL-SK-RO firmware that works on many countries and I doubt that is the problem.
I’ll give the installation another try this week-end; if unsuccessful I’ll jut put /e/ on it.