iodéOS und das Xperia XA2


I have now tried 2 times to flash iodèOS via USB connected to a Windows PC using the flash-all.bat from on my XA2. Both times dubious messages appeared in the terminal and after the error messages and the automatic reboot my previous OS started again.

Then I downloaded an older version of iodéOS and installed the iodéOS recovery according to the installation instructions from Lineage Install LineageOS on pioneer | LineageOS Wiki.

After removing the USB cable and starting the recovery, in both cases the recovery did not recognize the SD card with the iodéOS zip file. Then the second time I tried it via USB and a memory stick, which was recognized immediately and I was able to install the iodèOS.

Would be nice if anyone could fix/repair the installation on an Xperia XA2 times.


1 Like

Hi, I also had similar problems with, apparently because of a missing fastboot USB driver. After installing a Sony driver as described here Installing Sailfish X on XA2 using Windows - Jolla the installation went through. However some features surprised me:
(I) after the fresh installation iode was configured with the same PIN, that I was using with the previous Android version of Sony,
(ii) the fingerprint unlock was already working, as if iode used the information from the previous Android installation,
(iii) Google store and Google apps (Chrome, Gmail, Google Docks etc.) were still installed.

Is this an expected behavior?? Or has my installation of iode somehow failed?

After I’ve uninstalled Google apps iode seems to be working fine.

I have seen behaviour like that when I installed a custom ROM over a stock Android installation without wiping and formatting the data partition: screen lock (pattern in my case) was unchanged, and some stock Google apps were present, though they didn’t work. Because there was nothing I wanted to keep, I formatted my data partition with TWRP recovery, and everything worked as expected for a new installation


This is the advantage of a recovery with which I can delete and in my opinion a necessary step before a new installation.

I think that’s exactly what has happened: at some stage after starting the flash-all.bat script an error pop-up appeared and stayed. After I’ve clicked this pop-up away the installation continued and iode was installed anyway.

The question is, do I still have to wipe the data partition for iode to function properly? Or is it sufficient to just uninstall Google apps? After I’ve uninstalled Google apps iode seems to be working just fine, so I am hesitant to reformat the data partition, as all the apps which I’ve already installed from F-Droid would have to be reinstalled again after the reformatting.

It may be enough to just uninstall Google apps. I would also uninstall / re-install anything that was installed on the stock ROM before you installed IodéOS. That may not be necessary but …

1 Like