Iode OS wont boot after update 3.5

Hallo, I have a big Problem. My Samsung Galaxy S9 won’t boot into OS after the latest update. I’ve tried to install the update through the Recovery Mode - but no success. I’ve tried also to use adb to backup my data from the internal storage, but I cant connect with the devices, because I could’nt revoke the usb debugging. Can I get help pls? :slight_smile:

Hallo, ich habe ein großes Problem. Mein Samsung Galaxy S9 lässt sich nach dem letzten Update nicht mehr in das Betriebssystem booten. Ich habe versucht, das Update durch den Recovery-Modus zu installieren - aber kein Erfolg. Ich habe auch versucht, adb zu verwenden, um meine Daten aus dem internen Speicher zu sichern, aber ich kann nicht mit den Geräten verbinden, weil ich die usb-Debugging nicht widerrufen konnte. Kann ich Hilfe bekommen bitte? :slight_smile:

An update to iodéOS v3 has been made available by mistake for Samsung 9 series running iodéOS v2, but due to a change in the encryption method, this update requires a factory reset (we already communicated on this subject). This update has been withdrawn yesterday and the update to 2.10 proposed instead. This wrong update cannot be installed anymore through the updater since yesterday.

You won’t be able to recover your system, a factory reset will be required. The only thing you can do is to try to save part of your data, if your data partition is not encrypted. For this, you have to install the twrp recovery which can be found here: Download twrp-3.7.0_9-0-starlte.img.

To install twrp you need heimdall (Heimdall | Glass Echidna). On linux Ubuntu you can simply install it by typing:

sudo apt install heimdall-flash

Then, to install twrp, you must boot in Download mode (green screen) by pressing and holding Power + Vol down + Bixby, and typing in a command line environment:

heimdall flash --RECOVERY twrp-3.7.0_9-0-starlte.img

The device reboots shortly after finishing the flash. Before it reboots you must press and hold Power + Vol Up + Bixby to reboot into the recovery.
In twrp, go to “Mount”, then select the “Data” checkbox. If the checkbox can be selected, your data is not encrypted and you can save some part of your data (at least photos, downloaded files, …) by installing adb (How to install ADB on Windows, macOS, and Linux) and typing:

adb pull /sdcard

We are very sorry for the trouble caused by our wrong manipulation on this update…

My G960F doesn’t get past the splash screen after the update from Jan 31st. Is that the same issue?

Can you please make/link an official guide on what to do?

Edit, related threads:

Yes same issue, I’m sorry.
See message above for trying to save your data.
You must then make a factory reset in recovery.

Still think a nice, bepictured step-by-step and official guide would be the least iodé can do in this situation seeing it’s a pretty big mistake. Again, I installed yesterday. The update was offered up until at least yesterday. A small forum post that the user has to dig out is a bit insufficient not a 100% trustworty.

Edit: see edit in post below (this is getting on my nerves!)

I tried the instructions on windows. Managed to put the pohne in recovery mode, but get this when I connect it:


and unsurprisingly running heimdall does not work, when the phone is not recoginzed over USB.

And even if I fix that one, I still get:


Managed to flash twrp by switching to Linux, but it’s not booting into twrp after the flash, even if I press Power + Vol Down + Bixby in time, the phone just goes right back to the green screen that I entered to flash twrp in the first place - no sign of a menu or twrp. (See image in my opening post because the message board software doesn’t allow new users more than one image per post).

I CANNOT ENTER TWRP no matter what I do.

Btw. Heimdall has a --no-reboot option to make it easier to go into recovery mode before reboot.

sudo heimdall flash --verbose --no-reboot --RECOVERY twrp-3.7.0_9-0-starlte.img

Could it be that twrp is not supported for the G960F? @vince31fr

My bad, sorry. To enter recovery : Power + Vol UP + Bixby.

Okay, that works. What if I can’t select Data, as in it doesn’t let me select the checkbox? Even if I leave Data unselected, I can’t go on to the next step. Console says “Failed to mount ‘/data’ (Invalid argument)”

So your data is encrypted, you cannot backup it through twrp. I don’t know what else could be tried.

Is there an official support? Gotta say, I’m pretty mad, there’s MFA stuff on there, I would need for work.

Also, why is there no recovery for encrypted data? Can’t they just give you a key or something at first boot?


So @vince31fr what do I do now? How do I at least get the phone working again, i.e. factory-rest it? Feel free to point me to a support person, if you want.

FDE has been abandoned by google, so interest and development for tools supporting it (like recoveries) has stopped. And there were some technical difficulties to implement decryption in recoveries.
To perform a factory reset, you need to come back to iodéOS recovery (trwp does not do it appropriately in that case): flash this file ( with heimdall like you did for twrp, and perform the factory reset in the recovery.

Also I needed to format the data partition. In twrp that option is a bit hidden.

Yes but it will probably won’t work with twrp (maybe the last version ?). Prefer iodé recovery.

It did work. My phone functions again be it with complete dataloss and a day worth of efford. No offence, I’m sure you’re doing your best, but this whole ordeal is not a flaming advertisement for iodé

1 Like