Iodé browser different versions, same phones (Fairphone 5)

Me and my wife have a brand new Fairphone 5 and both are flashed with iodé. However, there’s something peculiar about the iodé browser.

My phone:

  • Pocket is available on the home page
  • Shows “Autofill” in settings
  • Payment methods and address can be saved in autofill

Wife’s phone:

  • Pocket is not available on the home page
  • Shows “Payment methods” in settings
  • Payment methods, but not addresses, can be saved.

I’ve noticed that my version has a few more megabytes of app size compared to my wife’s version. I’ve also tried removing the preinstalled app and installing from the fdroid store, but the result is the same. Both are also the same version number. Our iodéOS versions are the same, same Android version, same build number, same security patches… I’m just at a loss as to why this could be, any help would be greatly appreciated.

same iode blocker app settings?

Yes, I didn’t make any changes to the default on either device. Just in case though, I temporarily disabled the blocker on my wife’s phone to see if it restored these features. It didn’t have any affect.

same browser version?
check in app settings

Yeah, that was one of the first things I checked. The preinstalled version ends in 92 and the Fdroid version in 93. Currently we’re both on the Fdroid version (125.3.0-iode.93). I’m curious as to what the default behaviour is supposed to be (Pocket or no pocket, payment method and address autofill or payment method autofill only).

Just in case it matters since I’m aware this is unusual for this phone, we’re both using T-Mobile in the United States. My wife has a normal SIM card, but my setup is a bit different.

I have the Data with Paired DIGITS high speed plan. This plan uses the same MSISDN as the paired phone so that the phone number is shared across the devices. It’s typically used with smart watches. In my case, the paired phone is an iPhone which basically does nothing but hold the primary SIM and sits at home . You can think of it as a decoy or authentication token depending on how you look at it.

I’m using it for two purposes:

  1. Convince Apple to use my phone number for iMessage communications (I’m using BlueBubbles on iode to talk with iMessage users).
  2. Use the data channel over the cellular network instead of the constant connection like a regular phone call. This hides my calls and texts as regular data over IP (VOIP and ToIP) which will ping seemingly random towers at various moments. This has the affect of reducing the ability to use cellular triangulation tracking. (Honestly, this whole point might be incorrect, it’s just something I realized could be true but there’s no way for me to check).

maybe you can crosscheck with fennec, if there is the same behaviour

1 Like

The thought-provoking stories from Pocket don’t show up on either Fennec install.

My phone has both autofill options (addresses and payment methods)

Wife’s phone has payment method autofill only.

ok, understand
all things I personally don’t use
nor do i use a firefox based browser on my phone
cromite on phone and librewolf on linux desktop

so, sorry, i cannot help here anymore and have no ideas left

Thanks for the effort anyway

I did find this page here about it

Which shows various about:config options but you can’t access about:config within iode for some reason. I’m also not sure what I might test in Fennec. Changing them didn’t seem to do anything with Fennec.

The GeoIP of me and my wife should be United States. She does have Vietnamese added to the phone in addition to English though.

So I just figured out what this issue was and honestly it seems like a bug, but I’m not sure whose shoulders it would be resting on (IodeOS or Firefox for Android (Fenix) which Iode Browser forks from). Just in case though, I will tag this.
Bug reports

Thought-provoking stories by Pocket is removed if you set Languages > Regional Preferences > Temperature to Fahrenheit instead of Use default.

Address auto-fill is removed if you add a system language such as Vietnamese. If you remove the language, you have to clear the Iode browser activity (by swiping away in recents) to see address auto-fill as an option again.

@AlphaElwedritsch Even though you didn’t directly solve the issue, I appreciate you racking my brain around. Thank you.

as i know, but no 100% sure, iode is compiling it’s version from upstream, not from source.
removing just some blobs, telemetrie and adding qwant as search engine
it’s not on iode to fix it, at least not as long they change not the process

I agree with that much regarding the browser itself which is why I didn’t mention it by name. However, I’m not sure about the iodeOS itself since the solution involved changing system settings. The issue could either be iodeOS pushing strange locale settings or it could be Firefox upstream detecting the correct locale information and responding in a strange way. The particular oddity is Fahrenheit vs Use default even though both will use Fahrenheit in the Breezy Weather app.