Iodé 4.3 on unsupported Pixel 7a: Smart Charging and SafetyNet

So far iodéOS (4.3, 18 July version) is running really well on this phone but there are some issues it would be nice to fix or at least know more about.

The main one is Smart Charging, I’m a big fan of this feature! It’s in the settings but doesn’t work. Is there a simple fix to include the configuration for it when building? Charging Control is not in the build. If Smart Charging is not available could this be included instead?

The build instructions include a guide to passing safety net but so far this has never worked; it fails with “CTS profile does not match”. The that appears in the is the same as the fingerprint found directly from stock rom. Following the guide and adding another line to the makes no difference. Well, on google it is described as if that might make a difference?

Charging control should be available on Pixel 7 family: gs201: Build Lineage Health HAL · LineageOS/android_device_google_gs201@827b097 · GitHub
Smart charging will be removed in the next release, it’s now superseded by charging control and conflicts with charging control on some devices.

There have been issues with SafetyNet due to some changes in the way the test is performed. There will be a fix in the next release, and the modifications we made have as a consequence that passing safetynet will now require no addition: it should work out-of-the-box without the requirements actually described in the iodéOS build description.

Ah, thanks for the info! I checked out your link and I now see the relevant lines in their respective makefiles. Since I repo synced early yesterday it seems a new was created so hopefully next build that completes I’ll be able to see Charging Control.

Look forward to seeing how the SafetyNet behaves also.

Sources of the last release are available.

1 Like

Build completed ok and I’ve dirty flashed it to device. There is a minor problem with the Settings app that I suspect a clean install with format data might sort out. EDIT: fresh install/format sorted it out.

Charging Control is now here! I’ll test it later. EDIT: Does not work and no opion to set a % limit.

SafetyNet not passing but if I install again it might. EDIT: Nope, same result. I don’t need it though.

Here’s a screenshot of the Settings app info and another of the System settings page:

(the second screenshot I have encountered the weird “%1$s” characters before but that time they were at the head of the microg settings page. reinstall with wipe sorted it that time)

The charge limit mode has been temporarily disabled in lineage for all pixel devices.
About safetynet: bad news… That’s curious however, as it works without any addition on all the devices we support.

1 Like