Installing iodé on Samsung S5e

Hi all, I was delighted to read the news of iodé being available for the Samsung S5e tablet.

I’m trying to get this installed on my S5e but am running into issues, wondering if anybody here has tried this yet?

What I have done so far: (following iode / ota · GitLab)

  • checked I was on latest stock firmware
  • Unlocked OEM
  • accessed bootloader via ADB
  • unlocked bootloader via the Download Mode screen
  • gotten the latest vbmeta.img, recovery.img and rom.zip, made tars out of the first two
  • rebooted to Download Mode and trying to flash vbmeta.tar with Odin4 like so:
./odin4 -a ../Samsung-SE5/vbmeta.tar

to which I get the following response:

Check file : ../Samsung-SE5/vbmeta.tar
/dev/bus/usb/001/013
/dev/bus/usb/001/013
Setup Connection
initializeConnection
Receive PIT Info
success getpit
Upload Binaries
vbmeta.img
Fail request receive -5
FAIL! (Auth)
Fail uploadBinaries

I have tried various versions of Odin, including an older Odin3 on a Windows PC, but none succeed. This leads me to believe that I have not properly or fully unlocked the device, but I am not certain. Reading on some /e/ forums, a suggestion is that KG STATUS : PRENORMAL may be an issue? Below is a pic of the information I have in my DL mode.

I’m looking for any tips or info on how to move forwards with this, I’d love to get iodé on to this tablet :slight_smile:

Thanks for your help & time;

Best regards,

Colm

@colm
:de:Das Gerät scheint für eine Woche gesperrt zu sein. Am besten erst mal abwarten…dann nochmal…

:uk:The device seems to be blocked for a week. Best to wait and see…then again…Translated with deepl

I don’t know what solved this issue, but I did two things and when I checked KG STATUS after these, the flash was possible:

  1. I relocked the bootloader, and then unlocked it again
  2. I inserted a SIM card (I have the LTE model of this device) and registered on the network.

As I say, after these two operations, which I carried out as a way of trying to change this KG STATUS to show something different to PRENORMAL (as seen in the photograph of the Download Mode), something happened, and the status changed to CHECKING.

I was then able to flash the vbmeta.tar, recovery.tar and eventually the iodé rom itself.

My S5e is running iodé 5.1 and it works like a dream! Thanks all and thanks IODÉ