How to install iodéOS on a Google Pixel 4

Hello dear iodéOS community,

I installed iodéOS on several devices: Samsung Galaxy 9, Teracube 2e and Sony Xperia XA2. Worked perfect.

Now, I have a Google Pixel 4 of a friend and I am supposed to install iodéOS. I’m a little bit confused because of the installation instructions: They are really short and there is no recovery. Comperad to the instructions for /e/ OS or LineageOS. Especially for LOS, they write:

Warning: Before following these instructions please ensure that the device is currently using Android 13.0.0 firmware.
If your current installation is newer or older than Android 13.0.0, please upgrade or downgrade to the required version before proceeding (guides can be found on the internet!).

What do you think? Can I just follow the iodéOS instructions? I’m a little bit careful, because it’s not my device.


Hi yorrick,

There’s more than one way to skin a cat but since you are doing this for a friend, yes, the careful approach would be best. Rest in the knowledge that Pixels are easy devices to flash and hard to do any damage.

The iodé instructions are short because they describe the fastboot flashing method which is simple: download the iodeOS fastboot zip, verify it, extract it, open terminal in extracted folder and run the flashall script to install.

I will give my recommended approach without getting too sidetracked explaining things; but feel free to ask questions.

First make sure pixel 4, flame, is on latest google build. Check it against the google factory images page (here you can see fastboot flashing information as well by the way.

I will assume it is up to date. For belt and braces safety I would say make sure flame has this same build on the other slot. This is easy to do by sideloading an OTA build of the same version from the factory images OTA page. Follow the instructions at the top of that page.

Now flame is updated to latest stock on both slots you can prepare to flash the iode fastboot zip.

Check the shasum of the download. Make sure phone has usb debugging enabled and follow the iode instructions. When the script is running do not touch the phone unless asked by the terminal output (like for unlocking bootloader). Lock at the end when prompted.

Hey chrisrg,

wow, thanks for your really helpful answer!

I will install in the next days and report here or scream for help… :wink:


Hi Yorrick, which teracube model do you have installed please? Emerald or Zirconia? Can you please give the version you have installed and the step-by-step process. I can’t do it with the indications on the site. I’ve tried several versions of fastboot, the sh linux and bat windows scripts, typing the commands manually… adb & fastboot communications work but the installation crashes. I’m sure there’s something missing, but what can I do? So I’ve put /e/ back in without any problems in the meantime. But I prefer iode, no need for an ecosystem and all the applications that go with it. Thanks again.

Hey chrisrg,

finally I managed it to install iodéOS on the Pixel 4.

My first tries with my Debian 11 computer where not really satisfying, there where some barricades (which could be avoided with better documentation/manual): One example is, that you have to run the flash script not alone with “” but with “./”. But the installation did not start. The console said , that my SDK platform tools are to old. So I found a reddit post where someone wrote:

Right click the “flash-all” windows batch file and edit with notepad. Go to the line:

fastboot flash bootloader bootloader-blueline-xxxxxxxxxxxx.img

Delete everything above this line, and save the file. Then run. This disables the fastboot version check and just runs the batch file.

After doing this, the installation started and it seemed that it worked. But the device always restarted into fastboot mode. Nevertheless the LOS recovery was installed. So I tried to install via adb. But it stopped immediately with some errors (21).
After some more tries and always restarting into fastboot mode, I finally changed from my Debian 11 computer to my Debian 12 laptop. Same command line output: SDK Platform tools are to old. Did the same as before and…wonder! it worked.

Thanks for encouraging me!


Hey iodeclem,

sorry, the device is not in my hands: I gave it away and I have no clue which version it was and how exactly I did it (it was at the beginning of 2022). But I am pretty sure, that I did it not with the flash script but with adb sideload.


Edit: Just got the information from the new owner, that it is the Teracube 2e and the serial number says it is from 2020.

Another question about iodéOS on the Pixel:

The installation works well and there are no problems. But…

We did not relock the bootloader and did not uncheck “OEM unlocking” in the in developer settings after the installation. Just forgot it.

Since a few days the device does not start every time: Sometimes it is stuck with the iodéOS logo. When we long press the power button, the device starts normal after several trials.

Could the reason be that we did not relock the bootloader? And besides, is it save to relock it now with the running system? Does relocking the bootloader reset the system to the factory settings?

No idea what may cause the start up problem but don’t think it would be anything to do with unlocked bootloader.

You can relock at any time but it will factory reset . Locking and unlocking triggers a wipe.

but don’t think it would be anything to do with unlocked bootloader.

Yeah, thought so, too.

Locking and unlocking triggers a wipe.

Thanks for the information.