How to install from Google Play intentionally

Try using aurora store with you google credentials instead of webbrowser

Through Aurora I can install indeed, but then upon opening the app, it says: “Please install this app from Google Play”
Strangely enough, I did set up my Google account inside Aurora. But it seems that Aurora still applies the spoofed Fake Account. That is why I tried to circumvent Aurora and go to Google Play directly.

Anyway, no solution found yet. Other ideas?

What apps are you talking from?

For example FreeStyle LibreLink.

To resume:
Aurora does not do the job. Tried 2 accounts (my Google account and spoof account)
Not any browser does the job. Tried IodéFirefox and DuckDuck (logged in with Google account)

Did I miss a setting in MicroG?

I installed the app for testing and have the same issue
Have you configured microG with your google account?
But, in the end, for me it seems that this is a kind of app, that only works with uoriginal play store services, and not with spoofed microG
there are several apps left, that does not work without play services
sad but true…

to be clear
it is not aurora store, iodèOS, microG.
It is the app which checks play services. that’s a big f***k. And the app developers are to blame. no one else

<<Have you configured microG with your google account?>>

Yes, I did.
It did not help though!

<<it is not aurora store, iodèOS, microG.>>

OK, but do you have any clue why the browser-GooglePlay route does not work? Is Iodé blocking some communication (firewalling), and could that block be temporally halted?

No, sorry
have no google account and do not do such things, normally…

It seems, you’re not the only one.
seems a licensing issue

I hate such behavior and avoid this crap apps.
just a shame if you depend on it.

if you need this app for health reasons, then you probably can’t avoid a system with GAPPS

Very Crappy indeed

(by the way, I suppose the Brotcast is yours. In that case: thanks for your super manual to install IodéOS on FP4.)


i wear hearing aids myself and i’m really happy that the sonova/unitron app runs without any problems without google services. we will see how long it continues :wink:

1 Like

put both apps in that list:

I don’t know how exactly but it works through your Google account and with the official Play Store app : when you click install from the website, the app gets added somewhere in your Google account, then the official Play Store client notices it and downloads the app when it’s running in the background. Aurora Store does not implement this, I doubt it would be feasible.

If you like, pls place these on the compatable app list:
xDrip+ (health), blood glucose monitoring
Patched Freestyle LibreLink, (health), blood glucose monitoring

Note: the patching (adaptation) of the Freestyle LibreLink app is actively discouraged by its developer Abbott. Suggestion: search for the adequate links via xDrip+.

Interesting regarding A13

THX AlphaElwedritsch,
Fortunately, the IodéOS Android13 implementation (version 4.0-20230131-FP4) communicates perfectly with my glucose sensor.


For the problem, that some developers are checking if their apps are installed by “original” Playstore, calyxOS seem to have a solution to make the app spoof the originals when installed from the aurora store.

So in general, it seems to be possible…but i have no knowledge of the magik behind :wink:

The first implementation of that is in iodé 2+3 since several months (but commited them very recently in iodé 4), this is a simple spoof in the framework when there’s a request to know which installer has been used for an app :

This can fool some apps which use this kind of requests, but not apps that call that part of the google play api which is not implemented in microG.

1 Like

Author here. Glad to find that this was useful for someone :slight_smile: Open to suggestions for improvement!