Google Play services in Aurora (?)


I checked today my aurora store as I run a couple of basic apps that were coded requiring GSF use (google framework services). Aurora store proposes me to update Google play services(Gps) with its last version, the update comes from Google LLC, apparently.

I run anonymously Aurora store, I don’t have any google account.

Seeing the description of this update, and that this bug has already appeared for another OS

I wanted to notice it, and ask what to do with this for IodeOS: blacklisting Gps from Aurora, expecting the next Aurora update to fix this ?

Thank you.

you have to blacklist them in aurora
Do not update them
Comming from microG and aurora is detecting it as original play services

1 Like

To add some technical explanations: microG has the same package name ( as the official play services, in order to replace its functionalities. On this basis, Aurora store thinks that google play store is installed and proposes an update. This update could not succeed if attempted, as the signatures of the two apps differ: so trying to update is harmless. Blacklisting it is the best option, to avoid continuously seeing it (with failures when updating all installed apps).

1 Like