Galaxy A52s 5G no Wi-Fi network

Hello,
my Galaxy A52s 5G(bought 04.Feb.2024 @Inodé) was delivered yesterday, 09.Feb.2024.
Running through the setup there was no Wi-Fi connection discovered so I had to skip to get on.
This did not surprise me because my wifi network does not support DHCP.
Other stock-android mobiles can be switched to manual ip/DNS/proxy configuration by pressing the symbol within the Wi-Fi-setup for few seconds.
But I am unable to do this within iodéOS, maybe there is something I miss?

As my old mobile SIM is too old to fit in the newer A52 I just went on without inserting another SIMcard.
I presume there is no need to insert a SIM card to set up the phone and get at least the Wi-Fi connection running?

I found two ways to activate the Wi-Fi:

  1. “Network_and_Internet-Internet”(within Settings)
    -Shows Internet: Networks available (but Wi-Fi is shown as off(greyed out on the left!)
    If I hit the button to the on position… it moves to the right(on) and stays there but nothing else happens.
    Below it says:
    Network preferences
    “Wi-Fi doesn’t turn back on automatically”
    And after some minutes it switch back to off position.

  2. swaying from top to bottom on the “Home” Screen to get the quick access “Internet>”
    This seems to me as the “main” Wi-Fi switch so i gave it a try and touched this button and confirmed this with “done”.
    Now there is a moving bar but it says no networks available.

Back to step “1” there it says: Networks available. But NO Network name is shown and this button… is still in the off position.

Using the “reset your internet…” button… did not help.

Moving to a store with open free wi-fi(this time with DHCP) did also not help. NO connections found, no connections shown.

I cant even add the phone to my local Wi-Fi as I dont know the MAC address(shown as unavailable under AboutPhone-Device Wi-Fi MAC address).
Same goes with IP address: I CANT enter nothing there as well.

Switched the iodé protection level to OFF. Changed nothing.

I tried even the system recovery… Wiped the data… and did all the stuff above again. No Wi-Fi seen.

Please advise … maybe its a really stupid mistake by my side but I am thankful for any advise…

Hi

I also (test)use an A52s 5G with Iodé 4.9 and -without- a SIMcard but no issue’s with WiFi.
I’m not an employe of Iodé or anything, just an interested user.
Having DHCP switched off or not has no effect on the visibility of your access-point’s SSID.
Do other devices “see” your access-point’s SSID?
Only thing I can think of, is the WiFi region-setting. Can’t find this setting in Iodé to be honest.
You can change settings like DHCP per saved WiFi-connection, once you’ve connected to an access-point/router.

In the past some phones’ WiFi didn’t work on all European channels unless a SIM-card had been inserted. Never quite understood how and in which part of the software this was implemented.

If your SSID is visible to other devices, I would first try a inserting a SIMcard and check if you’re phone connects to the mobile network. This might set region-settings (-speculation-).
BTW, there are templates which you can print on a piece of paper to help cut the SIMcard in the exact dimensions, but it’s a delicate procedure and there is a risk damaging the SIMcard’s slot, if the card has not perfect dimensions and/or edges are too sharp.

Thank you for your reply,
forget to mention that my phone is still on iodéOS 4.8.
Today I put a SIM-card into the phone, and the update for iodéOS 4.9(Jan,18th 2024) was shown.

The screen showed the weather in the town I were so internet access was given through the local LTE connection.
Tried an access point given from another phone but still no network detected. (with working SIM-Card).
Sorry for no screenshot, would be easier to see… -.-

The “Internet” page from settings still shows Wi-Fi as disabled. Stays on when pressed for some minutes and switches back to off position automatically.
The Internet from the drop down menu is still ON searching for networks(no networks available).

What did you do to get the to Network details “page” as shown in the picture?
Or will it only show if at least ONE connection to Wi-Fi has been found(and stored)?
On stock androids and even those bitten-apple phones you have to touch for some seconds to open the detailed settings but i am unable to do this using the iodéOS…

You can see details below
systemsettings
network & internet
Internet
saved networks
then select one
then the pen at the top right

Because of the wifi shutdown, look under network preferences…turn off wifi automatic…what time is set.
I would set it to off to test

Thank you for this new piece of info :slight_smile:
But the problem is: Phone came fresh from iodé and it did not find any wifi network so under saved networks there is … nothing yet.

Network preferences:
Turn on Wi-Fi automatically (ON)
Notify for public networks(ON)
Install certificate (empty, I dont know what to do with certificates or what use they may have so i did not touch this)

Following your suggestion I switched “Turn on Wi-Fi automatically” to OFF position.

I think there is a misunderstanding

i mean turn off wifi automatically set to off.

was it set to 10 seconds?

Err. There are only two options: ON/OFF. Nothing about a delay time.

To hopefully clarify one or two things:
The “swipe down” menu (from the top of the main screen) showing:
Internet
Bluetooth
Torch
Do not disturb

The Internet> Button is highlighted and when i touch it it says:
Internet No networks available
Wi-FI (__O) (in ON position)
There is also a bar running from left to right(maybe to show it is scanning)

Different Menu: Using Settings-Network and Internet:
Globe with ? Internet: Networks available
Hitting the globe shows:
Internet
WiFi (O__) OFF position
Hitting button to on position button moves to (__O) on position but nothing happens.
When leaving this menu and going back… wifi is off again -.-

Cant see a delay time by either menues.

Ok, i tried setting up a hotspot. Even with “Turn off hotspot automatically” (O__) deactivated the Wifi hotspot deactivates itself after roughly 20 seconds.


Turn off Wi-Fi automatically (is missing in my phone maybe due to iodéOS 4.8?)
I will try to get the update ready tomorrow. Maybe something good will happen (fingers bend and crossed!)

Updated the phone to 4.9, now the Turn-off-Wi-Fi automatically shows up as well.
But nothing changes. Wifi is set to ON. No network shown, other AP invisible.
WiFi does still NOT work with this phone. Sad.
Have to ask support tomorrow about it.
Maybe I accidently deleted the WiFi App? :smiley: