FP4 - Stuck in fastboot mode - relock the bootloader

Hallo all,
now it happend to me :frowning:

i tried to relock the bootloader, but i forgot to push the custom key.
Now my FP4 did not boot anymore and only fastboot is available - when I select the recovery mode then it starts again in fastboot mode.

I installed iodeos 3.3 in the correct way with unlocked bootloader and i did not unlock_critical!

Everything went right an the os installation was completed. I did the first start and activated adb again.

For the last step, i wanted to relock the bootloader.

i tested : fastboot flashing get_unlock_ability
(bootloader) get_unlock_ability: 1
OKAY [ 0.000s]

And now locked the bootloader. That it …

I tried to erase the key

I started from beginning with flash recovery and then installing the key.
but i can´t reach adb

adb : List of devices attached
811xxxx unauthorized

after flashing again the recovery no adb connection was possible - so a sideload was not possible

No chance - only the bootloader - fastbootmode is available.

Seems to be bricked ?! Or had anyone an idea here?

That would be wonderfull.

thanks and greetings


Hello all,
After a restless night, I read around again (here and in the Fairphone forum) and tried to determine or set the active recovery partition.

fastboot devices
811xxxxx fastboot

fastboot getvar current-slot
current-slot: b
Finished. Total time: 0.016s

fastboot --set-active=b
Setting current slot to ‘b’ OKAY [ 0.016s]
Finished. Total time: 0.016s

then I was able to start the recovery again :))

And the access via adb worked as well

So the sideload of the iodeos 3.3 with adb was possible and after some time of installation, i could start my phone inti iode again. very very happy

I didn´t wipe and erase data and didn´t reset via recovery, because i tried these steps yesterday.

And so the last question is whether it is now possible to lock the bootloader again. In some other way - or not if its to risky.