FP3 stuck in splash after 3.5 update

Dear everyone, i updated my FP3 from 3.4 to 3.5 yesterday night. The first reboot seemed ok, although 3.4 was still oddly showing in the update list and I deleted. After that, I had to switch off phone. When rebooting, phone whould get stuck in splash screen. I have tried to adb sideload 3.5 multiple times, did not work. Then tried to flash iode-3.5-20230131-FP3-recovery.img in fastboot, then adb sideload update. Nothing, still stuck in splash. Can someone please help?

P.s. I have also tried to boot recovery img & then sideload .zip to both slots a and b but did not do the trick.

probably only a recovery factory reset can bring success.
Unfortunately, all data will then be gone

yeah, that’s what I did. Can you please recommend a backup tool for iodé I can use before every OTA/upgrade from this point on?

means, it is working now?

only included seedvault is possible. but not all apps can be backed up.
there are other possibilities, but require root, or at least adb root, and that’s not possible in official iodè builds.

Means yes 3.5 is working, but I had to reset everything and lost my personal data, Thanks, will do backup with seedvault next time before OTA.