Failing to install iodéOS on Fairphone 5

Hey everyone,

I’m running into an issue when trying to install iodéOS on my fairphone 5 with the iodeOS installer for linux. I have enabled OEM unlocking and USB debugging and the iodeOS installer makes my phone go to the boot menu.

The iodeOS installer then keeps hanging on the screen in this picture:

I have a few options with my fairphone when in the boot menu:

  1. Start → starts my phone like normal.
  2. Restart → the phone goes black and then returns to the boot menu.
  3. Reboot in recovery mode → gives a new menu.
  4. Power off → turns the phone off.

It looks like the iodeOS installer does not detect my device anymore after the previous steps. When I unplug my phone from the computer, the installer remains on the same screen.

Does anyone know how to proceed from here?

I would have liked to attach more pictures for reference but the forum doesn’t allow me because I’m a new user.

If your run windows on your computer, I suspect a driver problem. Check the device manager when your phone is connected in bootloader mode (which should be the case, at this stage).

screenshot looks like gnome shell

for me, seems more:

  1. bad usb cable (use a good cable, shuld be USB-A to USB-C)
  2. try another USB port

Flashing as non-root

On traditional Linux distributions, USB devices cannot be used as non-root without udev rules for each type of device. This is not an issue for other platforms.

On Arch Linux, install the android-udev package. On Debian and Ubuntu, install the android-sdk-platform-tools-common package.

that common package ist mandatory
otherwise, the device will be detected, also with adb devices but fails when trying to install a ROM
doesn’t matter if fastboot, sideload or installer (i think)

Oh yes indeed. Maybe add your user to the plugdev group, or run the installer with sudo.

or sudo -iand run it in root context

Thank you for the help, I have done two things:

  1. Using a USB-A to USB-C cable instead of USB-C to USB-C.
  2. Installing the android-sdk-platform-tools-common package (I’m running Linux mint)

I am getting much further now, but it is still not installing iodeOS. I have gone through the entire process and the installer thinks iodeOS was installed, but when the phone boots, a factory FairphoneOS starts. I have tried relocking and not relocking the bootloader after installation, both give the same result of starting FairphoneOS.

The output from the iodeOS installer is in the image. It did not allow me to copy the text so I had to paste some screenshots together, that’s why it might look a little bit wonky. My phone automatically moves between a few different menus during the installation steps.

Does anyone know how to resolve this issue?
Thanks in advance.

I’m not much fimilar with Fairphone anymore
But for me it seems, that iode is installed, but it did not switch the slot

You can try this:

Bootloader change current slot

in Bootloader:
get fastboot getvar current-slot → current-slot: b
set fastboot --set-active=a
or vice versa

But I would suggest to keep the bootloader open until you checked that eveything works fine

Never mind, I tried it again and it worked. I used a different USB port on my computer, but not sure if that was the problem. I did not change anything else though. Thanks for the help!

ah, fine, congrats :+1: