F Droid repository update problem


It’s been a few days I’ve encountered this “problem” with F-droid, using a Sony Xa2 phone.

It concerns the update of the store repository: it’s doesn’t update it. It’s probably a problem with F-droid, though f droid repository neither IodeOS app wouldn’t be updated. There are several topics about it.

As I’m part of the lambda users of IodeOS, I wanted to know if it was a known bug or if it’s a weakness coming from my phone, as my phone sometimes disconnects from Wifi sources.

Thank you.

This is a known issue, due to important changes in the way FDroid handles repositories, that caused us some trouble and yields this problem for some users. A iodéOS release is coming soon that will solve that issue. In the meantime, you can manually install the FDroid update that will be embedded in the upcoming release : fdroid/FDroid-29.apk at master · iodeOS/fdroid · GitHub

Ok, thanks, yes, it’s what I read too.

thank you for the 3.6 update and the team good work.


1 Like

I’ve installed the 1.16-iode.29 version, but no dice. The repos are still empty after updating.

There may be an deeper problem then, as 1.16-iode.29 forces a database clear and complete fetch.
You have then to clear f-droid storage (long-press f-droid icon, go to app infos, clear storage).

1 Like

Hi all,

Having this same issue on Fairphone4.

I tried reinstalling via the Apps settings menu, in the preinstalled apps section (requires a reboot for uninstall and reinstall)

I also tried the version linked in the post above and clearing any memory. I’m still getting the same error (Cannot update, are you connected to the internet?) message, see attached image.

You must go to app infos (long press fdroid icon), go to network and mobile data, and reactivate the network (it is disabled when an update of a system is uninstalled).

1 Like

Ah, great, so simple, yet I didn’t even think to look there. Thanks!