Bootloop after installation iodèOS on Xiaome Mi 10 Lite


I am new in Custom ROMs and my first choice was iodéOS, because it sounds like a good project, that is more easy to handle for an beginner than “normal LineageOS”.

I have to smartphones that i tried to flash. Both are Xiaomi Mi 10 Lite 5G Modells. (One for my wife and one for me.)
I am running installation by this instruction from LineageOS, because the instruction from iodéOS was to minimalistic for me.

This run without any problems with the first smartphone and i can run iodéOS.
But doing the same steps with the second one, after flashing the iodèOS-ZIP-File and rebooting, the device run into an bootloop.

Searching in the web doesn’t help me solving the probelm. Maybe i am looking for the wrong keywords.

Can anybody help me “repair” the device and bring iodéOS up to running?


PS: Sorry for my bad english.

Hi, you maybe forgot to format data ?

No, I format date/cache in the process.

I forgot to write:
I done the complete installation process (inclusive installation of the custom recovery) two times. So i am sure that i don’t forget some steps.

Are there any option to find out where the starting process is hanging and why the system is rebooting?

Do you see iode boot screen?

No, I don’t see the iodèOS Bootscreen.

I can see the “Mi” Logo. Than comes a short acoustical signal (“piep”) and the system reboot.

To end the bootloop i have to go into recovery menu and click the “Power Off” option.

If you can boot into bootloader from recovory, please enter following command and enter output here

fastboot oem device-info

And second question, the recovery is the iodes (lineage) recovery? Not xiaomis?

Device-Info from fastboot:

-> fastboot.exe oem device-info

(bootloader) Verity mode: true
(bootloader) Device unlocked: true
(bootloader) Device critical unlocked: true
(bootloader) Charger screen enabled: true
OKAY [  0.000s]
Finished. Total time: 0.000s

I installed the iodèOS recovery.

On the Website from TWRP-Projekt i found the information, that some devices from Xiaomi uses Android Verified Boot (AVB) and Dynamic Partitions.

Could this cause the problem? And if yes, what can i do?

That looks all good
No, you dont need a avb custom key

I would do following

Enter recovery
Format data / factory reset
Install iode image via sideload again
Check the output. All must be succeed!
Do a factory reset again
Boot system

Dont need to install recovery again. It is ok.
Your problem is only the image

Download image again, maybe it is corrupted
I would use the latest beta for monet. It is very stable. I use it without problems.

Its all ok with you device. Only image was not installed correctly. Thats the only issue.

Get latest monet beta from here:

Ok, I will try today evening or tomorrow.
Thank you very much.

1 Like

Please give feedback

I will help as much i can

It doesn’t work … :frowning:
(Foto from output while installation at the end of the post.

I testet the beta version, iodéOS 3.2, iodéOS 3.1 and an “normal LineaeOS”.
Nothing work. But it feels like the reboot loop needs more time after i tryed installation so often …

In the LineageOS recovery i saw, that there is an mount/unmount option.
Is this possibly an partition-problem? Do somebody know, what this mount-function from lineageOS do and whether it could be helpful? Or should i try TWRP to reset all partitions?

For me, the output of the screenshot looks absolutly OK.
I don’t really not know what happens on this device.

Unfortunately, I am not familiar with TWRP and cannot give you any instructions or recommendations.

Unfortunately, I can’t think of anything else at the moment on how to solve the problem.

So, I testet a lot with TWRP and found error that comes very often:

error while opening: '/data/media' (No such file or directory)

Could this cause the problem, that some directory is missing?

Or is there any place, where i can found an error log or something?

Hello, I solved the problem! :slight_smile:

Very strange, but it run!

After a lot of testing with TWRP and trying some other ROMs from XDA, the solution was the PixelExperience ROM.
I think the problem was the Android Verified Boot (AVB), wich was activated on this phone. (But i am not sure.)

Steps to reproduce/solve:

  1. Download of PixelExperience ROM
  2. Installation of PixelExperience recovery
  3. Booting into the PixelExperience Recovery
    → run the factory reset
    → Apply by ADB the file
  4. Running PixelExperience one time
  5. Booting into the PixelExperience Recovery
    → run the factory reset
    → Apply by ADB the file
  6. Running iodeOS
  7. Reinstallation TWRP again
    → Now TWRP asks for password at start. Clicking cancel works.

(I hope this was all and the solution was not influenced by my try-and-error-clicking bevor. :thinking:)

So it seems, that PixelExperience do some dark magic while installation, that was missing by iodéOS …
But my skill is to low to search it in the *.zip files.

PS: Should/could i inform the developer/maintainer of iodéOS about this strange behaviour of some devices and the “solution”? And what would be the right channel for this information?

1 Like

Fine that it works
But strange, because you other mi10 lite and mine could be installed without pixel experience rom

@Andreas and another question: What is your intension to use TWRP?
It is not needed, really.
The only advantage to use it is to have to possibility to do a Nandroid-Backup. In my Opinion.

have you used it before you did the initial installation of iodeOS, or during your tests?

Because, what I think, if there is really a problem in iode`s zip image file, why have other Mi10 lite users no problem to install it, like me?

That’s why I think the only diffenrence is TWRP which could do something in recovery or loader to prevent iodeOS to boot…

When i startet with the installation of iodé i used the iodé-recovery. With the other phone this works fine.

TWRP was only one tool in the testing orgy yesterday. But i think, it is an good tool.
I found it in some forum threads an starts testing, because it have some more options for reset and repair the partitions, Dynamic Partitions could be disabled, file system and logfiles could be shown and a lot of other high level configuration options.

Normally this would not be necessary. But my case was not normal …

An while all these testing i found, that twrp has two interessting options. Maybe also for the iodé-recovery for future:

  1. The backup and recovery functions. So that an old image could be recovered, when something goes wrong.
  2. Since newer Versions of TWRP the recovery menu (bootloader) could be saved with an password. I think this could be interesting for people who feel a bit unsave because of the unlocked bootloader. (For example in this discussion.)

Furthermore i had to think about the password function of twrp tonight.
Because when i started testing with twrp, it doesn’t ask for the password when i logged into the bootloader. After i could repair the device using PixelExperience ROM and installed twrp again, i was asked for password.
Yesterday evening i installed twrp on the other device, where installation of iodé run without problems. I was directly asked for password.
So maybe, the iodéOS-zip File wasn’t the problem. It would also be possible, that something was wrong with the partitions or permissions to write or something like that. Maybe PixelExperience don’t try to write in the existing partitions but delete them completly and create new ones.
But these are only some ideas about the cause of the problem. Now it is not reconsructable and i hope it will not happen again.

I think, when i finished the migration to iodéOS, i will use the old devices and test the backuup and recovery functionality of twrp. And after this i will decide if i do this in the futher with twrp or i switch back to iodéOS recovery.

Hi Andreas,
i had exactly the same problem! The problem is the Firmeware!!
You sould use a " global firmware “.
I my case, i installed Firmware " fw_monet_miui_MONETGlobal_V13.0.4.0.SJIMIXM_fd908f0df4_12.0”.
Your installed Los Recovery should work !