Beim telefonieren kein Audio / No audio during phone calls

Nachdem ich mir gestern iodéOS relativ problemlos installiert habe, habe ich heute festgestellt, dass ich damit nicht mehr normal telefonieren kann. Anrufen und Anrufe annehmen funktioniert, allerdings höre ich die Gegenseite nicht und die hört mich nicht, also kein Audio beim telefonieren. Ich habe die Berechtigungen schon mehrfach geprüft, auch schon eine andere Telefon-App getestet, aus- und wieder eingeschaltet, die Telefon-Apps komplett deinstalliert und wieder installiert. Sprachanrufe über verschiedene Messenger funktionieren. Ich habe den Eindruck das das Problem nicht bei den Apps oder normalen Berechtigungen liegt, sondern im Betriebssystem selber. Hat jemand ähnliche Probleme und/oder weiß eine Lösung?

After installing iodéOS yesterday without any problems, I realized today that I can no longer make normal calls. Calling and answering calls works, but I can’t hear the other party and they can’t hear me, so there’s no audio when I’m on the phone. I have already checked the permissions several times, tested another phone app, switched it off and on again, completely uninstalled the phone apps and reinstalled them. Voice calls via various messengers work. I have the impression that the problem is not with the apps or normal permissions, but with the operating system itself. Does anyone have similar problems and/or know a solution?

Fairphone 3
iodéOS 4.11

There’s a few additional things that I would check:

  • Check if the microphone itself is blocked from the Quicktile (Pull down from the notifications to see the selectable tiles, one should be for microphone). This is different from the microphone permission for the Phone app.
  • Settings > Network & Internet > SIMs > [Network Providers Name]. From this section, ensure your carrier settings are correct. You will probably want to check Access Point Names at the bottom as well as enable 4G Calling and optionally Roaming. Of course, Mobile Data isn’t related to voice but good to enable too.

You can also start by checking if your microphone works in the recorder app. If it does, it’s more likely a network issue.

Thank you for your answer

Check if the microphone itself is blocked from the Quicktile (Pull down from the notifications to see the selectable tiles, one should be for microphone). This is different from the microphone permission for the Phone app.

I have already checked this and unfortunately this is not the problem.

Settings > Network & Internet > SIMs > [Network Providers Name]. From this section, ensure your carrier settings are correct. You will probably want to check Access Point Names at the bottom as well as enable 4G Calling and optionally Roaming. Of course, Mobile Data isn’t related to voice but good to enable too.

I have also checked this without success. I will test it again tonight with a different SIM card, but I don’t think that’s the problem.

You can also start by checking if your microphone works in the recorder app. If it does, it’s more likely a network issue.

The microphone and speakers work well in all other apps, I can also send voice messages and calls via various messengers also work. The microphone also works in the recorder app.

I found a possible solution in the XDA forum, but I would have to root the phone to do this, so I’ll wait a little longer, maybe someone here has a solution. In the XDA forum there is a suspicion that it is due to a wrong lineage configuration, but since the thread is a bit older, I don’t want to tinker with any configuration values yet.

Jetzt funktioniert es endlich so wie es soll. Das Problem lag vermutlich daran, dass ich iodéOS über eine zu alte Android Version installiert habe.

  1. Ich habe also erst einmal das aktuellste FairphoneOS installiert (das gibt es hier: https://support.fairphone.com/hc/en-us/articles/18896094650513-Installing-Fairphone-OS-Manually
  2. Nachdem das installiert war funktionierte das telefonieren wieder so wie es sollte
  3. Nun habe ich wieder iodéOS installiert. Diesmal gab es auch keine Probleme beim installieren.
  4. Jetzt funktioniert das telefonieren wieder so wie es soll.

Ich vermute, dass beim installieren des aktuellen FairphoneOS auch irgendwelche Hardware Treiber aktualisiert wurden.

[en]
Now it finally works as it should. The problem was probably due to the fact that I installed iodéOS over an Android version that was too old.

  1. so I first installed the latest FairphoneOS (available here: https://support.fairphone.com/hc/en-us/articles/18896094650513-Installing-Fairphone-OS-Manually
  2. after that was installed, the phone worked again as it should
  3. now I installed iodéOS again. This time there were no problems with the installation.
  4. now the phone works as it should.

I suspect that some hardware drivers were also updated when installing the latest FairphoneOS.