Aurora Store fails to connect when iode's blocker is active

I purchased a Samsung S9 with iode on it.

For months now (probably since mid 2023), I’ve had difficulties opening the Aurora Store, which I have ignored so far as most of my apps are available via FDroid. But as my current DBNavigator app does not work anymore, I needed to upgrade that via Aurora.

When trying to login with any of the anonymous account options, the login fails after ~30 seconds:

When taking a look at iode’s blocker, it seems it has blocked Aurora from sending data to
Screenshot removed due to Forum media limit for new users:

After switching off iode’s blocker, Aurora instantly returns a maintenance message:
Screenshot removed due to Forum media limit for new users:

I retried logging in for a few hours, always with the same result, and the same is true after rebooting the S9 and on another day.
This was happening with the current iode OS 4.9 and the most recent Aurora 4.4.1, as well as at least with iode 4.7 and Aurora 4.3.x.

I then uninstalled Aurora via Settings|Apps|Pre-installed apps, rebooted the phone and installed it via FDroid instead.

Login attempts still produce failures to connect to after 30 seconds when iode’s blocker is active.
But disabling iode’s blocker now allows Aurora to login successfully,

I’d appreciate if Aurora Store would not be blocked.

Should/would I need to buy iode’s premium account to allow me to whitelist Aurora?

As I am not allowed to post more than one image, I wanted to update my post with an image combining my three screnshots, but it seems I can’t edit my post anymore after a week. Posting it as a reply instead:

Hey there,

did iodé 4.10 and aurora store 4.4.2 fix your problem?

Best regards,

No, still the same.

That’s strange, I’ve never had Aurorastore blocked under any configuration. Currently I have aurora under reinforced protection (as I have been testing blocker with all apps under reinforced).

Have you tried “data reset” in the blocker settings? Also try clear cache in the blocker “app info” (long press app icon) and maybe even clear storage as well.

1 Like

Indeed, resetting data allows me to login to Aurora again - thank you!

For reference, this is how that option in iode’s settings screen looks in German:

Out of interest:
Any idea how keeping that data would have managed to block for me?

No idea how the blocking happened in the first place, it’s a mystery; but hopefully by resetting the app data it will not return!