App needs google play services

Hi guys
I have need an App that needs google play services.
I have the microg iode apps installed but still i get the messages. What do i need to do to be able to use the app?

Thanks for your help

what messages and which app?


The Message that the App needs the google services.
The App is RIDE. An Uber like Ethiopian alternative usable in Addis Ababa

I have just tried the app on my device. Works ok, but quite a lot of traffic in the blocker app that I would normally block!

Device is on iodeOS 4.10 beta.
Microg is not signed in or switched on to google services .

Check your iode blocker, or even try turning it off.

You may need to clear the storage of the Ride app to start it fresh.

When do you get the message about google services? When you open the app?

Just right at the beginning. The app doesnt even start
Tried all the things. Do you have any special settings?

No special settings. Blocker protection is set to Standard for microg and Ride.

Ride app got from Aurora store.

What iodeOS version are you on?