APK install permission info missing

when an APK App is installed, there is no info about the permissions from the App. Last, i used cyanogenmod, and with this, the permissions was displayed by the install process. The problem is, websites like Pure APK don’t display the permissions.

The further question is, i use iodé on a Teracube 2e, and it was written, that this device can not use iodé 3. So the question is, what about updates that offer new features? I’m a little bit confusing to by a device with an expired OS.

The other problem is, F-Droid and Pure APK offers many outdated Apps and there is no other possibility as to install it to find out if they worked. By this, there is the problem with the permission info.

The situation is not so easy and i think about it was better to by every (two/three) year a cheap throwaway device with newest fully android. Please make the situation better.

The most you say is android specific and not touched by iode and also out of scope of development

Since a few Android releases, permissions are required at runtime. This may happen anytime, depending on how app devs decide to ask them. We did not modify permission behavior wrt LineageOS/Android.

We backport all our additions to previous maintained LineageOS/Android releases. Actually, Android 11 (LineageOS 18), 12 (LineageOS 19) ,13 (LineageOS 20) all receive regular security updates and iodé developments. However, Android/LineageOS refinements are generally not backported, so some embedded apps in previous versions do not evolve anymore.

The Teracube staff is working to provide a better support of LineageOS, so they should, at some point in time receive OS upgrades. In the meantime, previous Android versions are as secure as newest ones.

Thanks for your answers. It seems all not so easy. My last phone was a Moto G (1). So it has worked for 9 years. It worked flawlessly with an old cyanogenmod until the battery broke (no more charging possible. Battery already crashed at 40% / 50% / 60% / 80% before). Unfortunately, no newer cyanogenmod could be installed after 4 years. This is about the same problem as with Ubuntu (Linux). Old hardware that still works fine, like my good old Pentium III laptop, is not supported. And I have other old computers that still work, but only with old software. About this, there is the question, why a replaceable battery? Smartphones become outdated not only because of the hardware, but much more because of the software. The Teracube 2e is not much faster than the Moto G (1) in most applications.