Anyone using BRS Golf app with IodéOS?

I use the BRS Golf app which has worked fine on several versions of /e/OS and LineageOS. When I try to use it on IodéOS, I see an error screen immediately after logging in.

I am running a home-made, unofficial build of IodéOS 4.0 on my Sony Xperia XZ1 Compact (lilac). I am not sure whether the problem is with my build, or whether it occurs on official IodeOS builds as well.

Is there anybody here who already uses this app.

If not, is there anyone who would be prepared to install the app and try it out with my login details (which I will share via private message)?

Thanks very much

Can test it directly tomorrow morning on my pix 5
Give me you credentials via pm if you want, i will forget it immediately :wink:

Thanks. You will shortly have a message

I also just tried it with my earlier 3.4 build, and got the same error.

The log cat output can be found here

The solution was to turn off blocking for the app.

This is not the recommended solution though, just a test. What you could do next, is to find the domain(s) responsible of the issue. To do that:

  • enable the blocker again for the app
  • enable, one by one, the domains that are blocked by the app (just for this app, no need to enable them globally). You can do that in the Report tab, and tapping on the app to go to its report page.
  • when the app works, keep only the last enabled domain, reblock all the other ones, and retry…

Domains on our black list can generally be blocked (and are all considered as “bad” domains), but it may happen, as in your app, that blocking them makes some apps dysfunction.

Thanks. I’ll give that a try, but I would like to get IodeOS setup on my ‘daily driver’ device first