Adb devices - does not recognise phone


I have installed adb on a ubuntu 18.04 OS. adb Version 1:8.1.0+r23-5~18.04

I can detect a non iode phone but not my iode Samasung 9

Any assistance will be appreciated.

what adb version is it in this ubuntu package?

adb --version

maybe the adb/fastboot version is too old.
current is 34.x
it should be a 33.x

often the USB cable or the USB port is also a problem.

Try a different USB cable and/or a different USB port

and just to be sure:
Have you enabled developer options and turned on USB debugging?

My version

It shows up as an adb device for a non iodé phone

Although the iodé phone is with developer enabled and usb debugging switched on.

Jepp, to old
Is 23. need at least 31

OK. I am using kodachi based on Ubuntu 18.04,
The repositories only have this.
So is there a way to install > 31 other than installing the complete Android studio IDE?

deinstall the complete android-sdk-platform-tools
You need at least one packet from your distro:

  1. android-sdk-platform-tools-common
    for preconfigured udev rules

download platform-tools for here:

and put it in your $PATH
or put all files from there to ~/bin (maybe you have to create it. and you have to re-login or reboot)

Did as instructed. Did not need to change udev rules, as my non iodé phone was also a Samsung.

However, error "adb server very (39) doesn’t match this client (41) n killing…* daemon. Started successfully

< No list of devices attached. >

for me, it seems it is still not the right adb version

sure your system is using the right adb binary?
the one from the new downloaded platform tools?

which adb

whereis adb

adb --version

to be sure, using the right adb command

$ which adb

$ whereis adb
adb: /usr/bin/adb /home/kodachi/opt/AndroidSDK/platform-tools/adb /usr/share/man/man1/adb.1.gz

$ adb --version
Android Debug Bridge version 1.0.41
Version 34.0.4-10411341
Installed as /home/kodachi/opt/AndroidSDK/platform-tools/adb
Running on Linux 5.4.0-112-generic (x86_64)

I tried connecting with a different USB cable, the third cable test and now the device
is recognised.

I think the update did the trick . Many thanks for you assistance.