Update iode-1.7-20220401-cepheus.zip impossible

Version EN

I updated my Xiaomi Mi 9a= with the latest version available, but my smartphone does not boot anymore.

Once on the Iodized logo, it stays for some time and then restarts in recovery.

I tried with a wipe cache and dalvik but didn’t want to do a total wipe, because I don’t want to lose my app settings.
Do you have the same problem?


Version FR


J’ai mis à jour mon Xiaomi Mi 9a= avec la dernière version disponible, mais mon smartphone ne démarre plus.

Une fois sur le logo Iodé, il reste quelque temps puis redémarre en recovery.

J’ai essayé avec un wipe cache et dalvik mais pas voulu faire un wipe total, car pas envie de perdre mes réglages d’app.
Avez-vous le même problème ?

Merci a vous

1 Like

Same thing here, stuck on boot. Help!

Version EN

@vince31fr Any ideas? I see that others have problems.

I tried with a wipe cache and davilk but the same.

I also recovered the old version and as a last resort installed the latest one directly from the recovery and even via adb sideload.

I put my old Galaxy S5 back on DivestOS.:wink:

Version FR

Une idée? Je vois que d’autres ont des problèmes

J’ai essayé avec un wipe cache et davilk mais pareils.

J’ai aussi récupéré l’ancienne version et en dernier recours installé la dernière directement depuis le recovery et même via adb sideload.

J’ai remis en route mon vieux Galaxy S5 sous DivestOS. :wink:

I’m investigating the issue.

Thanks Vince; anything we can do to help with debugging?

You can try to sideload this build that has just been uploaded : https://github.com/iodeOS/ota/releases/download/v1-cepheus/iode-1.7-20220406-cepheus.zip


It worked! Thank you so much!

Via adb sideload and command adb sideload /home/anthony/Téléchargements/iode-1.7-20220406-cepheus.zip ? for mi its not ok but i try via recovery

adb sideload or uploading to sdcard and flashing the file, that’s equivalent methods

1 Like

Okay when in doubt, I’ll give it a try.

So I guess it’s dead for me then.

I recovered the photos, the documents, now it’s the SMS and application configurations.

I would try, a backup via TWRP, to try to reinject it once a stable config is found.

Version EN

I am coming back to you to confirm that everything is back to normal thanks to the work of the IodéOS team.

I want to thank @vince31fr for the follow-up and the work done to solve this problem and I want to underline his professionalism.

Again, thank you for this wonderful OS and your availability.

Version FR

Je reviens vers vous pour vous confirmer que tout est revenu dans l’ordre grave au travail de l’equipe IodéOS.

Je tiens a remercier @vince31fr pour le suivi et le travail effectué pour resoudre ce problème et je tiens a souligner son professionnalisme.

Even if it worked, there was still an issue in this build, I found it with the invaluable help of @McFly in testing several builds (many thanks to you, too :slight_smile:). It seems now to be solved, and data can be recovered. This issue also appeared on a few other phones from different manufacturers. A new OTA update should be available within a couple of days.

1 Like