Samsung S9 OTA update from 2.9 to 3.5 offered


yesterday, 3.5 for Samsung S9 was released

today my phone offers me upgrade from 2.9 to 3.5

Is this OTA update working seamless? Because afair there is a change from “FullDiskEncryption” (FDE) to “FileBasedEncryption” (FBE)…is this done during the upgrade seamless or is this update turning the phone into factory reset state??

Just keep in mind that at least I have still issues with using “Seedvault”

During a short period of time, the upgrade from 2.9 to 3.5 for all Samsung 9 series has been offered, but this is due to a wrong manipulation on our side: effectively, the encryption change from FDE to FBE requires a data format.
This upgrade has been withdrawn, and an upgrade from 2.9 to 2.10 is now proposed. You should see it in the updater: isn’t it the case ? And/or do you still see the 3.5 upgrade ?

We apologize for the inconvenience. People, if any, that performed the upgrade, should now be stuck at the bootanimation. To recover, the 2.10 ota must be sideloaded in the recovery via adb.


I saw the most recent update and took it. and I don’t recall if it was 2.10 or 3.5. After the update my phone got stuck on the iode boot logo and didn’t boot no matter how much I’ve waited. I went on github and downloaded all the versions from 3.4 to 2.9 and tried flashing the image via Heimdall (Linux) and sideloaded the zip via adb. I haven’t factory reset my phone yet and while I was downgrading to 3.x versions it got stuck on the boot logo. But when I’ve started downgrading to 2.x versions it started to get stuck on “Downloading… Do not turn off target”. I really don’t want to lose data if possible, could you help me?

What you can try :

I have tried it and sadly I still get stuck at “Downloading…” screen. What should I do?

If the recovery has been properly flash, the problem is to reboot into it.
Does the recovery has been flashed ? Do you get an error message ?
To reboot into it from the Download screen, press and hold Power + Vol down until black screen, then quickly press Power + Vol up + Bixby.

I have flashed the recovery and i can reboot to it after i switch to the download mode.

At first I switch to download mode and run:

>heimdall flash --RECOVERY iode-2.10-20230131-starlte-recovery.img

Heimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna
This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:
Donate | Glass Echidna

Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…

Initialising protocol…
Protocol initialisation successful.

Beginning session…
Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device’s PIT file…
PIT file download successful.

Uploading RECOVERY
RECOVERY upload successful

Ending session…
Rebooting device…
Releasing device interface…

After that I switch to recovery mode and update with adb:

>adb sideload

serving: ‘’ (~93%) adb: failed to read command: Success

And after that it reboots into a seperate download mode where there is no text in the background and gets stuck there. (Manually launched mode has ODIN MODE written at the top)

Ok. I don’t see what else to try, the userdata partition may have been altered. I’m afraid that you now only have to factory reset, and I am very sorry.

The updater (even after cache/memory cleanup) still offers 3.5

It should be fixed.

Maybe your data partition was not encrypted: did you try install twrp and pull your data ? Explained here: Iode OS wont boot after update 3.5 - #2 by vince31fr

I updated samsung S9 with the iodé updater to 3.5.
And was stuck in the logo screen aftwards.
Followed your instructions here and flashed the recovery in download mode
Then I got to recovery menu and choose reboot to recovery.
The phone now displays reboot to recovery…

Doing adb on an usb connected computer just gives
adb sideload

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    adb: sideload connection failed: no devices/emulators found
    adb: trying pre-KitKat sideload method…
    adb: pre-KitKat sideload connection failed: no devices/emulators found

what can i do?

Try again “adb sideload …”, it sometimes has difficulties to start.
But I think this won’t be able to boot, and you’ll have to factory reset. See my post above to try to save some of your data.