Iodé Recovery 3.1 fails to install on Samsung S10e


@Mystic : thank you for your advice. If no solution is found with the standard Iodé method, I will try TWRP.

No problem try with TWRP and check if your bootloader is unlock sams as says @vince31fr

@vince31fr : yes : if I do step #4 again (In Download Mode, long press Vol+), my phone proposes me to lock the bootloader !

I just tried to install Iodé Recovery 3.0 instead of 3.1.
This failed too !

I read the instructions to install TWRP.
Among other things :

If you wish to install TWRP without rooting, there are numerous pitfalls to consider. For example, a stock device is protected by Android Verified Boot. This is implemented as a vbmeta partition that contains cryptographic digests for verifying the integrity of boot.img, recovery.img and other partitions/images. Flashing TWRP without first flashing a vbmeta image with verity disabled will render your device unable to boot.

This could explain why the Recoveries provided by Iodé are refused by the Samsung S10e.

On a side note, I would like to avoid rooting my device : I would like to use an app that refuses to run on rooted devices !

1 Like

The thing I don’t understand, is that I am not the first one to try the installation of Iodé to a S10e. If there was a problem, other users would have reported it.

Unless you all installed TWRP instead of the Iodé Recovery !

If someone reads this, and installed Iodé on an S10e with the method provided by Iodé, please tell us so.

Hallo Cobus,
ich kann Dir diese Seite empfehlen. Mach es nach dieser Vorlage. Es ist die beste Erklärung die ich kenne.

1 Like

Vielen Dank für Deine hilfe, @Sandy !
Soll das unbedingt so kompliziert sein ? :roll_eyes:
Mein deutsch ist wahrscheinlich nicht gut genug dafür.
Ich glaube sowieso, dass mein Handy nicht zu einer Android-Version unter 12 zurückkehren kann : meine AP Nummer ist G970FXXUFHVE1 (SW REV. F = Android 12).

Thanks a lot for your help, @Sandy !
Does it have to be so complicated ? :roll_eyes:
My german is probably not good enough for this.
Anyway, I don’t think my phone can go back to an Android version below 12 : my AP number is G970FXXUFHVE1 (SW REV. F = Android 12).


You must install exactly same version of recovery iodé same as stock firmware . Have you unlock your bootloader ?

Hello !

Do you mean that I must install a Iodé recovery version 3.1 (for Android 12) because I have a SW REV. F (= Android 12), or is it even more specific ?

Until now, yes (as I confirmed in post #7). I did the same things as in your video but update the phone (I fear to end-up with a firmware and software versions that are too new for the Iodé OS available).

But I just tried to lock my bootloader again (to be able to redo the unlocking process), and given I wiped everything, a fresh copy of Android 12 started. I had to enable developer options, (tap the Build Number 7 times). And now I don’t have the OEM unlock menu. I read that I must wait seven days to have it ! I tried to modify my phone’s date, to no avail.


I think you must install same version recovery iodé same as stock iodé firmware you would like install.
Try to wait 7 days if necessary.
it doesn’t look easy to install iodé on a samsung S10e
a new version of iodé is being prepared, maybe it will work better, I don’t know.

hello cobus,
you can try it like this…at least that’s how it works with the S9.

set date to manual
reset date 2 weeks
set Software updates to manual
developer options -----automatic update off
debug on
phone restart (must be connected to the internet)

then oem unlock should be enabled

hope it works at your phone


1 Like

Thanks a lot @sts61 ! The internet connection was the key I missed !


1 Like

I can now report a success !

• I could unlock the bootloader again, but had the same problem as I described in post #1.
• Thanks to the video that @Mystic pointed to in post #13, I noticed that my phone displayed KG STATE : Prenormal in Download Mode, while the phone in the video displayed KG STATE : Checking.
Reading revealed that KG STATE : Prenormal means that OEM unlock is OFF.
Explanation : right after one unlocks the bootloader, the Samsung S10e reboots. But it reboots with developper options OFF !
I used to shutdown the S10e when it wanted to begin the installation of Android. This time, I went on, reactivated Developer options and thanks to the trick provided by @sts61 activated OEM unlock again.
• I rebooted in Download Mode, and this time my phone displayed KG STATE : Checking. This time, the following steps succeded !

I could install Iodé Recovery 3.1 + Iodé OS 3.1, but the installation instructions need to be updated (double dash typo + additional steps to reactivate OEM unlock after unlocking the bootloader).

Now is the time for me to try Iodé OS 3.2 !

Moderators, you now can alter the subject to mark the problem as solved. Thank you all !


Hi, I try to install iode on a Samsung S10e. The latest firmware was installed, I managed to go back to a version from Sep 26 (SKHVI4), but when I try to install iode recovery, the message states that only official releases are allowed. Reason is the missing OEM unlock
I checked several links/sites, changed date to manual and all the other tweaks, no success, I can’t unlock the bootloader. In the video linked in #11, there is a menu option to unlock the BL, that is missing on my devices (Vol+ for a long time), my version looks different from that one.
Any other idea?
Frustrated greetings

Hello @laneb

Did you activate developper options (tap the Build Number 7 times) ?
Did you then have the OEM unlock menu ?
Could you switch the OEM unlock ON ?

there is no OEM unlock in my developer settings, USB debugging is active and as I wrote I tried different things to get OEM unlock, no success so far.
With a locked bootloader I can’t install a Non Samsung ROM

Theoretically, you must wait 7 days to have the OEM unlock menu.
But @sts61 provided a workaround that worked for me.

I set the date to mid of October (the new ROM Version is dated 26. September) , the rest as described, no OEM unlock

Now I have oem unlock
i set the date manually to today, disabled automatic installation, the phone looked for updates, I denied to install them now, rebooted again and now oem unlock is available. Strange, that it worked with the date of today.
Solved for me now, I hope that the rest of the installation works without problems.

1 Like