HELP! Update failed iodé 2.4

Hi everyone,
I have just tried to update from iodé 2.3 to iodé 2.4 on my Galaxy A5, after TWRP installed successfully, the phone booted and got stuck in the iodé splash screen. After about two minutes it booted back up with TWRP. If I restart it, the same problem occurs, please help me!

1 Like

I am the same probleme with my mi9

Same Problem with old teracube.
Disaster: Please do NOT provide untested OTA updates, it ruins everything!
Sideloading after failed OTA doesn’t help. Installation of recovery 2.4 and works fine (install completed with status 0), but still booting stops after logo and reboot to “factory reset” option.
On Teracube forum I red that removing lockscreen password is recommended. It seems there are still issues decrypting in TWRP with secure keyguard. Could that be the problem?

1 Like

We of course test our OTAs…
But we’re not a company with 200 engineers and cannot predict all possible cases of failure.
And even for these companies, OTAs sometimes fail on some devices.
Old 2e latest build has been downloaded 38 times since yesterday, A5 has been downloaded 54 times, so we can reasonably suppose that the builds work not so bad (these are the numbers given by github, publicly available).
BUT: one very common point in case of OTA failures (not always, but very often), and particularly for A5 and 2e, is that at some point, TWRP has been used. We do not support using another recovery than ours, Magisk and so on.
Mi9 is a bit different, there was an important change that worked well on our test devices, but that seems to cause trouble for some devices. We’re currently trying to investigate the issue with precious help from beta testers.
In all cases and even when TWRP has been used, we can try to investigate issues, but need data (logs, …) for issues that we cannot reproduce ourselves.

I used 2.3 recovery for update to 2.4 and let the updater do the job. Everything seems fine.
After failure I flashed TWRP to backup data, also without success, error: cannot create /data/media/0/twrp folder, required key not available.
If OTA is insecure, please write it in the updater message. Better a good sideload than a failing OTA.

Problem: there is no easy way to backup beforehand. Even TWRP backup is not easy and does not backup all data. And Iode has no TWRP backup.

After factory reset it shows iode 2.4, so the update itself worked. So iode didn’t find the data after update.

As said from vince before, TWRP is not supported
You can use seedvault to backup your data.

As I said before: I didn’t use TWRP for update

Hello all,
unfortunately I used TWRP 3.6.0_9-0 to install iodé. I am absolutely no expert in flashing costum roms etc., so I installed iodé following a youtube video, there TWRP was used. The instructions on the iodé website I unfortunately did not understand, so I could not use it.

For me it would now be important to get my smartphone running again and ideally not lose my data. I am currently a little lost and would be very grateful for help. If any data or logs are helpful for this, I will provide them, but I would need to be told how to create them. (I have absolutely no idea about costum-roms, flashing, sideload, recovery, etc).

Can someone please help me out of my predicament?
Thanks a lot!

We temporarily withdrawn the OTAs to investigate the issues that appear on some devices. For your device, a beta build will be available tomorrow, you can try to sideload it in recovery mode with adb. You can join the beta group on telegram if you wish, all feedback is welcome

But bear in mind that SeedVault

  1. will not back up all of your user apps and data (unlike TWRP)
  2. will not always successfully restore all the apps and data that it claimed to have backed up

If TWRP backup is not an option for your device, then you caould have a look at this project on XDA forums. It’s not as complete as TWRP backup, but it works significantly better than SeedVault, and has greater granularity (i.e. you can restore individual apps and their data) than both SeedVault ad TWRP.

1 Like