FP4 - Unable to relock bootloader

sorry, that was just a thought of mine if there are possibly two versions.
How and whether you can check this at all I do not know

I had this issue when i switched 2 times from e/os/ to iodéos and from iodéos to /e/os.
Relocking with /e/os installed on it the second time make the phone corrupted.
Going back to iodéos os and relocking was accepted.

It didn’t make my phone bricked i was able to unlock and relock the phone althought it was corrupted.
It just can’t boot.

Maybe a full recovery to stock rom before flash again to iode solve this ?
Does someone tried to make a full flash to srtock rom ?

Hello,

perhaps I have some good news.
I have installed the iode OS Version 2.4 Beta and I can lock the bootloader without any errors.

What OS and Version did you use before?

Iode 2.3 for Fairphone 4 from the Iode Website.

OK, so you did just do an update.
But, was your bootloader unlocked on 2.3? And why?

Hallo,

the bootloader is unlocked becouse when I locked the bootloader with 2.3, I get the error that my Fairphone is corrupt and the phone will not boot.

So, I left the bootloader unlocked and the Fairphone will boot.

I have installed Iode OS 2.4 Beta desciped here
iodéOS 2.4 beta available (I have used the UpdaterIodeBetaAndroid11ToAndroid11V2.apk)

With Iode OS 2.4 Beta I can lock the bootloader and the Fairphone boots.
I have tested to unlock and lock the bootloader again and it worked.

3 Likes

OK. Thanks for sharing the information

Did you install the root key?
fastboot flash avb_custom_key
manually and additionally?

Hi guys,

I’m facing a very similar issue, did an installation on my FP4, everything ran smoothly until I tried to lock the bootloader again: after I did it, my phone just started to reboot over and over after 1sec of “Fairphone” screen loading , and there’s nothing I can do to go back to the bootloader, I tried with power and volume down, nothing to do, it keeps rebooting. That’s quite scary and quite upsetting, is there anything I can do to come back to the bootloader? Any idea ?
Thanks in advance.
[EDIT: I somehow managed to reboot with the bootloader by pressing volume down at a very precise timing, and repeated the installation process as indicated by @FairphoneHulk , thanks a lot for that. Now I still have fastboot unlocked, which is not great at all, but at least I can use my phone for some time…]

I had the same problem once and will post what I did here even though you already found your way out of the bootloop. But maybe someone else will find this useful:

  1. Remove any USB-C cable and turn off your Fairphone 4
  2. If you cannot turn your device off, remove the battery for a few seconds, then put it back in.
  3. Press and hold the “Volume Down” button.
  4. Insert a USB-C cable connected to power
  5. Release the Volume Down button as soon as you see the FAIRPHONE logo

@Damiens

Have you installed the avb custom key as mentioned in the install guide?
fastboot flash avb_custom_key avb_custom_key-FP4.bin

and when yes, could it be installed or did you see any errors?

Means, you have your phone running with iodéOS but still unlocked your bootloader?
That’s not a big problem. And, for the moment until it’s not clear what’s the problem is, I would leave it unlocked.

Yes I did install the avb custom key and it went smoothly, no error to report.
Sure, for now I will leave my phone unlocked, although I don’t really feel comfortable with this status.
The OS is cool and it feels good to be back on Lineage, I’ll wait until we find out more about this scaring issue.
Thank you for your following anyway, it’s much appreciated.

1 Like

Hey guys,

unfortunately I have the same issue as original posted. I just got a new Fairphone4, flashed (successfully) the avb custom key, installed iodéOS (2.4-20220407-FP4), and still… can’t lock the bootloader in the end without ending in a boot loop.
Are you aware that this issue still occurs with 2.4-20220407 and does maybe someone have a possible solution for me?

Cheers

Hello iodè friends,

I had the same problem yesterday with my new FP4 which I could not fix.
Here’s the link to the Fairphone forum:

I tried 20220405 and 20220407.

Thanks to FairphoneHulk, who helps me a lot. All the tip’s didn’t helps to lock the bootloader again, but helps to boot iodè.

Hopefully the system devs will found a solution.

Additionally, I read about some updates which requires to unlock the bootloader again to install.
That will also require wiping all data. For a guy like me it takes a day for reconfiguration.
Is this become very often?

No, wurzelsucher, once the correct avb_key is installed and bootloader is locked, everything is fine.
Updates will then receive via OTA, without wiping data.

Perfect. Hopefully this lock problem will be fixed.
If, I’ll make a special donation. Promised!

but, i think you will get a “better” and faster response if you asked about help and helping hands in the iodé matrix channel: #iodeOS:matrix.org

How can I get this matrix stuff?
Do I need a special app?

you can use element in browser:

or element app via f-droid store:
https://app.element.io/mobile_guide/

After you have create an account and loged in, you can search for iodé room and join