FP4 - Unable to relock bootloader

Hey there,

Firstly thank you for providing an alternative OS for the FP4 :slight_smile:
I yesterday got my Fairphone 4 and installed iodéOS on it. Sadly whenever I try to relock the bootloader (with the command ‘fastboot flashing lock’ because the command provided in the instructions ‘fastboot oem lock’ did not work. Same thing for unlocking) I get the following error message:

Your device is corrupt. It can't be trusted and will not boot

After that I get trapped in the bootloader not even able to get into recovery mode (Getting to recovery is only possible after entering ‘fastboot boot iode-2.3-20220126-FP4-recovery.img’ and installing everything all over again).

I really hope you can help me out here because I really want to use this OS with a locked bootloader.


Go back in bootloader
Unlock it again
Start from beginning with installation of recovery and iode
Leaf bottlader open
Start iode
It works then also the updater

You have no other chance at the moment
Problems with FP4 and relocking are known at the developers
Trying to find a solution

Do not try to relock it at the moment!!!

And do nothing with lock_critical or unlock_critical
This would brick it totally

At the moment you have a chance to unlock it again in boot mode

1 Like

Thank you for your reply.
If the problem is already known I’m going to wait until the devs fixed it.
Maybe someone should remove the locking part from the install instructions until it’s working as intended.

Have a nice day :slight_smile:

That is also already reported in the beta telegram group
should be done ASAP.

You’re safe until you do not relock the bootlaoder
You can use iodé without limitations and the updater works, too.

If you have no worries with an open bootloader, you don’t have to wait

You can try a solution that has been just posted in the beta telegram group, or wait for the next release that will hopefully solve this problem.

The next release will not solve the problem, as an additional step is required in the bootloader. You can follow the updated instructions on iode / ota · GitLab. In brief for you:

This defines iodéOS custom key as a root of trust used by the bootloader to verify rom authenticity, and permits to boot when the bootloader is relocked.

1 Like

I relocked my bootlader and everything works just fine. Does this only affect some devices? Or will I get issues in the future?

1 Like

Strangely it seems that not all devices are concerned, but maybe after a firmware upgrade you could get that issue. Probably not before unlocking your bootloader again though, but it’s difficult to tell.

1 Like

Thank you so much for your efforts! I will try your solution after I get a Nextcloud running for the integrated backup tool.

Seedvault works also with USB stick and often better :wink:


I have the same problem.
I installed the Fairphone 4 following the instructions and the command

fastboot flash avb_custom_key

Unfortunately, after relock the bootloader I get the error message

Your device is corrupt. It can’t be trusted and will not boot.

When I unlock the bootloader again iode starts.

I currently have two questions about the issue that the phone is corrupted when the bootloader is locked again.

  1. are there two hardware revisions of the FP4?
  2. Is it related to the last stock SW update of FP? 103.20220221 - February2022

In the 103.20220221 there is an interesting message in the changelog:
“Addressed an issue that was causing an incorrect message to be shown when trying to toggle the bootloader unlock function and no internet connection was available.”

It seems to me that those of us who have not had or are not having any problems have been using the previous version of the SW. 0132.20211027 The October 2021 version.

All the problems now being reported seem to be on the latest stick from February 2022.

Somehow it smells like it. Especially because of this changelog…
All PRoblems are reported by people who haven’t had their phone that long, or are on the new stock

And this does not only concern iodé, but also /e/OS and also the change back to stock. Even there it has massive problems.



yes I updated my Fairphone to the latest version Feburar 2022 before installing iode.

Where can I find the hardware revision of the Fairphone?

sorry, that was just a thought of mine if there are possibly two versions.
How and whether you can check this at all I do not know

I had this issue when i switched 2 times from e/os/ to iodéos and from iodéos to /e/os.
Relocking with /e/os installed on it the second time make the phone corrupted.
Going back to iodéos os and relocking was accepted.

It didn’t make my phone bricked i was able to unlock and relock the phone althought it was corrupted.
It just can’t boot.

Maybe a full recovery to stock rom before flash again to iode solve this ?
Does someone tried to make a full flash to srtock rom ?


perhaps I have some good news.
I have installed the iode OS Version 2.4 Beta and I can lock the bootloader without any errors.

What OS and Version did you use before?

Iode 2.3 for Fairphone 4 from the Iode Website.

OK, so you did just do an update.
But, was your bootloader unlocked on 2.3? And why?


the bootloader is unlocked becouse when I locked the bootloader with 2.3, I get the error that my Fairphone is corrupt and the phone will not boot.

So, I left the bootloader unlocked and the Fairphone will boot.

I have installed Iode OS 2.4 Beta desciped here
iodéOS 2.4 beta available (I have used the UpdaterIodeBetaAndroid11ToAndroid11V2.apk)

With Iode OS 2.4 Beta I can lock the bootloader and the Fairphone boots.
I have tested to unlock and lock the bootloader again and it worked.