Error installing IODE3.2 on Samsung Galaxy S9+

I am following step by step the installation procedure of IODEOS on a Samsung S9+.
And I have an error on the 5th step:
1 - Update last firmware → Done
2 - Switch to developer mode → Done
3 - Reboot and internet connection → Done
4 - press power/vol-/bixby mode download → Done
5 - Flash lineageOS with command (linux UBUNTU 22.04) :

sudo heimdall flash --RECOVERY iode-3.2-20221014-star2lte-recovery.img

Messages returned by the command:*
Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…
Initializing protocol…
ERROR: libusb error -7 whilst sending bulk transfer.
ERROR: Failed to send handshake! ERROR: Failed to receive handshake response. Result: -7
ERROR: Protocol initialization failed!
Releasing device interface…

I don’t understand why since I have a compatible phone.
Can you help me?


I just found out that the S9 isn’t like that. There really isn’t a step with the bootloader.
So now I don’t know anymore…

For other sammsung devices, there is a step more in description:
Before flashing recovery with heimdall
1. In Download Mode (DL), long press Vol+ and unlock bootloader

See description for S10 for example:
Step 4.

@Angilella But one question, have you enabled OEM unlock in developer settings?

It seems not.

Please check it.

How doing it:

thank you all the same

yes but it doesn’t work

Then i can only imagine that something is wrong with your Desktop OS (heimdall version, etc…), USB cable or USB port

This may be related to this issue : S10+ bootet nicht nach Installation
Although the problem with latest stock rom does prevent boot, not flashing

It’s not the same problem I think.
This person has managed to write data to his S10.
I can’t write any data via usb to my S9 with the heimdall command. An error in the transmission protocol.
Thank you in any case.

the error message indicates that communication could not be established.

  1. OEM unlocking not activated. The phone rejects the request
  2. hardware problems. USB cable, USB port, etc…
  3. software problems. Heimdal, Libraries, etc…

Samsung allows unlocking the bootloader but on the versions: Samsung Galaxy S8, Samsung Galaxy S9, and Samsung Galaxy MI note 8, the ‘OEM unlock’ Option only becomes available after 7 days of activating the device and adding a Samsung or Google account to the device.
I have only had mine for 5 days. Maybe that’s the problem. I’m waiting for Sunday

In the link ahead it is described how to do it without waiting.

So, you tell, OEM unlocking is still not activated. Then the error message is correct

my problem is that OEM unlock/lock is missing from the development options. Not even disabled. It’s not there.

Again, have you tried this:

as described from @sts61

Yes, several times. But I notice that @sts61’s case is different: for him, in the development options the OEM unlock section is disabled. In my case it is missing.

1 Like

Does your s9 have an exynos or snapdragon SoC ? I ask this because first we only support the exynos variant, and second the snapdragon variant may be unlockable through its stock rom.

I have a snapdragon

Do I have any hope of installing iode ?

What is the exact model name of your S9?

Model : S9+ SM-G965U

seems to be a US variant version and everything i can found in internet is, that it is not possible to unlock bootloader for this device. Only problem reports and no one could unlock it.
but maybe i am wrong…